post instillation problem

I have ubuntu 10.04. I installed just the base system…set a static ip on eth0. I then installed cloudmin. I rebooted and now the system is rejecting port 10k. How do i get access now?


Is it possible Webmin isnt’ started?

You can verify that by running this command:

/etc/init.d/webmin restart

After that, are you able to access port 10000?


well it wasn’t started that got it started. however i can still not reach the webmin. however now instead of just rejecting the connection attempt it times out.

Hmm, that’s odd. If you had a firewall blocking the port, it wouldn’t notice whether or not Webmin were started.

If you look in /var/webmin/miniserv.error, do you see any errors? In /var/webmin/miniserv.log, do you see any connection attempts?


does apparmor cause issues in ubuntu like selinux does in centos/rthel?

Nope! We’ve never seen issues with AppArmor.

That’s not to say there couldn’t ever be one, but for all the Ubuntu systems out there running Virtualmin, we hadn’t yet run into one where an issue was related to Apparmor. And it’s been friendly enough that we leave it running, unlike SELinux which would cause things to break if it were still enabled.


ok i did a complete reinstall to no avail. I’m really curious what is going on.

here’s my process:
I did a minimal install of ubuntu. i install joe and ssh. I then used the cloudmin kvm install for debian. I log into webmin and see the banner about i have to reobot to establish bridge. I then proceed to reboot and loose webmin connectivity. i sitll have ssh connectivity. what am i missing?

btw the machine is on the same physical network(aka same switch no vlans or firewalls) as my other boxes…so there’s no firewalls involved.

Some folks have run into problems on Ubuntu where Webmin isn’t starting properly… just to rule that out as a possibility now that you’ve rebooted again, can you make sure Webmin is running on your server there?


it was…still no dice. Centos6 doesn’t work right on this box but hyper-v and vmware do. I would prefer to use cloudmin though…any ideas?

joe others…any ideas? I’m going to statically assign two nics so hopefully i’ll be able to get into the box remotely…if i can joe any webmin staff want to take a look?

i figured out the nic install quirk with cent6 am going to try that and see what happens.

ok i do not like network manager at all in cent 6…back to ubuntu…need to get this bridging issue addressed…any ideas?

Use debian instead of ubuntu. It’s much stable in server side.

Also check if it listen

netstat -tupan |grep 10000
ps ax |grep webmin

and if it’s ok look at your iptables rules

I have installed over 20 times on debian and no such problem encounter