Post-Installation ClamAV


Don’t know if this is a bug. Just reinstalling my server as, when I last time installed it, and was running the Post-Installation, changed the ClamAV settings from “Keep using on-demand scanner” to “Yes”

On the next page, I decided, that I wanted to use the on-demand scanner anyway, but when I hit the “back” button, the options is gone.

I even ran the post-installation again afterwards, and now the options is still missing.

Have I done something wrong? If it’s not possible to return to on-demand scanner, maybe an clear warning should be presented when making the choice.

You do not want to use the on-demand scanner. I promise.

It is no longer feasible to use on-demand scanning with clamav. It is just too large and slow to start.

Until I get more ram for my server I don’t want to hammer the ram :smiley:

Then you can’t use ClamAV at all. Just disable AV scanning. It is too big for a low-memory server.

On-demand does not reduce memory usage of ClamAV, it just pounds on it at random, leading to OOM killer kicking in and killing random processes. It’s pretty much the worst possible scenario. At least clamd allows you to see how much memory it is using rather than springing up every time you receive mail.

Really, if you’re short of memory you can’t afford to run ClamAV.

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.