Phpmyadmin max database import size is stuck on 8MB

Hi guys,
this is driving me Fking nuts!!!

I cannot get a new virtual server to change its php max upload filesize beyond 8MB.

I have tried everything i know and nothing is working…gone into webmin, virtualmin, even created a phpinfo.php file and used file manager to go directly to the file it says is being used.

Server API FPM/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/7.4/fpm
Loaded Configuration File /etc/php/7.4/fpm/php.ini
Scan this dir for additional .ini files /etc/php/7.4/fpm/conf.d

Nothing i do is changing the max file upload size on this new virtual server. Its giving me the absolute shits wasting fking hours trying to get something so simple working.

Why on earth cant there just be a single fking place to sort this for a virtual server that over writes everything else? I shouldnt have to fck around going from place to place trying to find where this is being controlled from…just one click, i am there on a virtual server and that fking fixes it period!!!

there are other websites on this system, i dont want to be screwing them up…how do i force this fking thing to change on this virtual server?

Ok, try this:

Virtualmin -> Services -> PHP-FPM Configuration.

Important: Under the caption “Manage PHP Configuration” check if it is referencing the correct file - /etc/php/7.4/fpm/pool.d/158427459318760.conf for example.

If so, click Resource Limits and set Maximum HTTP POST size

If it’s phpmyadmin for a particular user, is there a php.ini file in /home/user/etc/php7.4 or some other per-user location?

There are a few php.ini settings that affect upload and post limits.

memory_limit
post_max_size
upload_max_filesize
file_uploads
max_file_uploads

It takes a lot of tweaking and restarts to get it right. Make sure to restart the correct php-fpm service when there’s more than one. Use a phpinfo() file to compare local and master columns after making changes.

There may also be MySQL limits to increase for PHP apps that connect to MySQL.

what i have noticed is that even the default Primary Domain on my virtualmin system is restricted to max file upload size of 8M.

in webmin>php configuration

i have set all versions of php in that location to the following (ie 5.6, 7.0, 7.1, 7.2, 7.3, 7.4)

Maximum memory allocation 128 Maximum HTTP POST size 64M
Maximum file upload size 64M Maximum execution time 180 seconds
Maximum input parsing time 60 seconds

phpinfo.php Loaded Configuration File /etc/php/7.3/fpm/php.ini

In virtualmin>Services>php-fpm configuration> resource limits:

Maximum memory allocation Default Maximum HTTP POST size Default
Maximum file upload size Default Maximum execution time Default
Maximum input parsing time Default

Surely the above settings should mean that any virtual server with php configuration settings set as default, should automatically be applying the webmin configuration?

i had to manually go in and edit the above file (Loaded Configuration File /etc/php/7.3/fpm/php.ini)…the Resource settings in Webmin and Virtualmin do nothing.

Is this even working properly in Wbmin and Virtualmin?

I am not convinced its even working…can someone check the above on their system and make sure this isnt a bug! (i run debian 9 and apache2).