phpMyAdmin continous login loop


Not sure if anyone has experienced this: but since i entered a password in the Mysql interface of Virtualmin, I get a continuous loop back to my login page threw the phpMyAdmin interface. I get no //wrong password error message// (none), just a loop back to the initial phpMyAdmin page. It was working fine before. I have unistalled it, purged it, dpkgd, and just about anything you could think of, even created new users with all the write permissions. But still get a continuous loop back. I have been trying to resolve this since yesterday. I have read just about every fix i could find for this weird occurance, and still no solution… I can access Mysql fine threw Virtualmin usermin and webmin.

I sure hope someone has gone threw this, and can make my life easier. I do not wish to reinstall everything, between ffmpeg, alien and all the rest of linux’s dependencies I have spent a week building up my server… /Dang/

Any one ever had the misfortune of this happening to them?

And could you post a fix.



Okay, I’m not sure I see anything in your htaccess which is causing an issue.

How are you installing phpMyAdmin – is that something you’re doing by hand, or are you using Virtualmin Pro’s built-in Script Installer?

I’m curious about two things:

  1. If you fully uninstall it, then delete the directory it was in – then re-install it, does that make a difference?

This is a long shot, but since you already tried reinstalling it, I figured it won’t hurt :slight_smile: But, it might solve the issue of some invalid files being in the directory.

  • I’m wondering if phpMyadmin is setup at all within Apache. I’m not sure if you’re using CentOS/RHEl or Debian/Ubuntu, but perhaps you could run a command to test for any phpMyAdmin code:

if on RHEL/CentOS

find /etc/httpd | xargs grep -i phpmyadmin 2>/dev/null

if on Debian/Ubuntu

find /etc/apache2 | xargs grep -i phpmyadmin 2>/dev/null

I don’t recommend reinstalling your system; if we don’t learn what’s causing the problem, it’s quite likely to occur again. And then we still have to figure this all out, but now you’ve spent a few hours redoing everything :slight_smile:

Thank you again to try and help figure this out.

I installed it threw the command: apt-get install myphpadmin.

I reinstalled it about 5 times with :

apt-get remove phpmyadmin
mv /etc/phpmyadmin /etc/phpmyadmin-old
apt-get install phpmyadmin
dpkg -P phpmyadmin
apt-get install phpmyadmin

I deleted all the files first.

The next step would be to uninstall Mysql And phpMyAdmin.

Not sure how to uninstall Mysql yet completely and i am afraid that it will mess up the setup because i used Virtualmin’s auto setup script witch works like a charm.

I have everything setup on an other sever and all works great. This happened to me on the other one as well but i can’t remember what i did to fix it.

It was working fine before I entered a password. This set up is on Virtual pc 2007. so I can bring it with me on my Xp laptop. If you like I could send you a zipped copy of it. It’s about 3 gigs so I would need an Ftp address and you could try it out. I would send you the Virtual pc 2007 .exe file as well it takes two minutes to install.It should work on your pc. Would would just need to change the static ip address on Debian (VPC)to your your own network ip address for it to access internet.

The command line you have included return : /etc/apache2 is a directory.

and if i include the (find)part nothing comes up.



Just a heads up about the forum. When try to edit my posts i get an :Oops! You’ve hit a bug in the forum software. It’ll be fixed soon.



Hi Ramy,

I don’t really recommend reinstalling MySQL.

I believe the issue is either with the phpMyadmin or Apache config, and I’m not sure which yet.

Is it possible to access a URL for your phpMyAdmin setup? I’d like to see the problem in action :slight_smile:

Seeing it on your box may be simpler than me getting Virtual PC working, as I’m not running Windows here :slight_smile:


let me figure out how i will do that. I will repost as soon as it’s done.


I do not have a static IP so will have to do some port and ip mapping i guess. There is an option i saw for this in webmin.


I have had the same issue – my solution was just to reload the page once I logged in. I think its a caching issue.


Thks for the reply. It would be nice to be able to login to phpMyadmin, but I am stock at the login page. Yesterday i tried to manually install the 3.1 version and i get the same issue with the add a server page. It does not create the page, just a continuous loop,.I tried different browser figuring it may be a browser issue, but still nothing. i am stumped… I looked up apache2 error log, but nothing.



Would be nice to be able to login, but thats where I am stuck. I tried to install 3.1 manually but even the add a server page continuously loops. it does not create a file. it just loops. Figuring maybe it’s a browser issue i tried 4 other ones, but still nothing and appache2 error log shows nothing pertaining to this. I am stumped…

While a try to configure my IP’s to give access to Eric i will try and clone my other server setup and install it on the problemed one and see what happens.



How do i delete my posts. Not quite sure how i managed to add 4 similar ones. So maybe my login issue is me, he, he :slight_smile:


How do i delete my posts.

You can’t. Another reason our current forums (actually it’s the URL management tool, but it shows up in the forum most painfully) suck. :wink:

New website is coming soon that fixes this issue, along with all of the other forum problems.

So maybe my login issue is me, he, he :)

Seems likely. Maybe cookies? What browser are you using?


I use Firefox, Netscape, Explorer 7-6-5.5( for displaying properly purposes) and Opera.



Again, with double posts. sheesh… :slight_smile:

Again, with double posts. sheesh... :)

Don’t click “Resend data” when your browser asks…For some reason sometimes the browser thinks you’re reloading the page. It’s stupid, I know. As has been mentioned, this forum will be killed soon.


After 4 days of trying to figure this out… I fixed by reinstalling everything starting by install mysql and phpMyAdmin before the Virtualmin auto script installer. Not sure if it is related. Now i need to reinstall all the rest of my sever (another 2 days) and will see if there is a conflict between any other program.


Thks again for trying to help!


After 4 days of trying to figure this out... I fixed by reinstalling everything starting by install mysql and phpMyAdmin before the Virtualmin auto script installer. Not sure if it is related.

I’m sure it’s not. :wink:

I'm sure it's not. ;-)

Probably true :slight_smile:

Great work on all of this programing you offer. two thumbs up!!!