phpMyAdmin 503 Forbidden Error, now worse

I’m working on migrating some websites to a new VPS and I’m using Webmin / Virtualmin to accomplish the task. I’ve gotten what feels like 90% of the way there, and I’ve been able to set up virtual servers, get the domains set up and wordpress running on the sites. However, I’m looking to get phpMyAdmin installed on one server because I understand that I can use that for all the other sites as well. I used the Install Script and everything ran smoothly, but when I tried to click the link to example.com/phpmyadmin, I got a “403 Forbidden You don’t have access to /phpmyadmin on this server” error.

I then ended up tinkering with the config file by trying to set “Allow from All” as a test to see if that was the issue, it wasn’t and i messed with some more stuff in there and I’m not sure exactly what I even did anymore.
Config file is located at /etc/httpd/conf.d/phpMyAdmin.conf and I think I made the problem worse.

Now I get three errors, which you can see at http://www.antiquelighthouses.com/phpmyadmin/
for example:
“Not Found - The requested URL /phpmyadmin/navigation.php< was not found on this server.”
“Not Found - The requested URL /phpmyadmin/< was not found on this server.”
“Not Found - The requested URL /phpmyadmin/navigation.php< was not found on this server.”

If anyone can help me figure this out it would be greatly appreciated. Is this an issue with a php setting, the phpmyadmin configuration itself, or something else entirely?

Howdy,

Using the Install Script, it should be possible to install phpMyAdmin into any of your domains, and that should work out of the box.

However, having a phpMyAdmin RPM installed can cause problems, as that works in a way that isn’t compatible with the Virtualmin setup.

The phpMyAdmin.conf that you described typically comes with an RPM. If you rename that file to something else, are you then by chance able to access the /phpmyadmin/ URL on the domain where you installed the phpMyAdmin Install Script?

-Eric

Hi Eric,

I renamed the file, but the error is still persisting. What is a phpMyAdmin RPM, and if I installed it accidentally, how can I just uninstall it?

Thanks

Sorry, I failed to mention that after you rename that .conf file (to something not ending in .conf), you’d need to then restart Apache.

Renaming that file should be all you need to do in order to disable a phpMyAdmin RPM, if there’s one installed.

You can also run this command to see if there is one:

rpm -qa | grep -i phpmyadmin

That fixed it, thanks for saving me from myself!

# rpm -qa | grep -i phpmyadmin
phpMyAdmin-4.4.15.10-2.el7.noarch

What is the location of the phpmyadmin.conf file?
Why does the Virtualmin install of phpmyadmin have this error rather than work out of the box?