PHPMyAdmin 403 Forbidden

I installed PHPMyadmin in a folder on one of the virtualhosts and it comes up 403 Forbidden. I installed it using the built in script installer. Any ideas on how to get this to work. The other weird thing is I tried installing it on another subserver, but I get “This script cannot be installed, as this virtual server does not meet its requirements : phpMyAdmin requires a MySQL database”


Do you perhaps have a distro’s phpMyAdmin package installed?

If so, that might be overriding your Install Script, and attempting to run the distro version, which could cause the error you’re seeing.

What distro is it that you’re using?


I don’t think I have the distro’s phpmyadmin installed. I’m using CentOS 6.

Not sure if it helps, but here is what the Access Log says. - - [19/May/2014:04:48:23 +0000] “GET /phpmyadmin/ HTTP/1.1” 403 213 “-” “Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0”


Just to be sure – what is the output of this command:

rpm -qa | grep -i phpmyadmin

Also, is there a .htaccess file in the public_html? If so, what are it’s contents?


There was no output when I ran that command.

This is the .htaccess in the public_html. I have Roundcube in the root and phpmyadmin in a folder.

# AddDefaultCharset UTF-8 AddType text/x-component .htc php_flag display_errors Off php_flag log_errors On # php_value error_log logs/errors

php_value upload_max_filesize 5M
php_value post_max_size 6M
php_value memory_limit 64M

php_flag register_globals Off
php_flag zlib.output_compression Off
php_flag magic_quotes_gpc Off
php_flag magic_quotes_runtime Off
php_flag zend.ze1_compatibility_mode Off
php_flag suhosin.session.encrypt Off

#php_value session.cookie_path /
php_flag session.auto_start Off
php_value session.gc_maxlifetime 21600
php_value session.gc_divisor 500
php_value session.gc_probability 1

RewriteEngine On RewriteRule ^favicon\.ico$ skins/larry/images/favicon.ico

security rules:

- deny access to files not containing a dot or starting with a dot

in all locations except installer directory

RewriteRule ^(?!installer)(.?[^.]+)$ - [F]

- deny access to some locations

RewriteRule ^/?(.git|.tx|SQL|bin|config|logs|temp|tests|program/(include|lib|localization|steps)) - [F]

- deny access to some documentation files

RewriteRule /?(|composer.json-dist|composer.json|package.xml)$ - [F]

SetOutputFilter DEFLATE # replace 'append' with 'merge' for Apache version 2.2.9 and later #Header append Cache-Control public env=!NO_CACHE ExpiresActive On ExpiresDefault "access plus 1 month"

FileETag MTime Size

Options -Indexes


Have you an issue for this problem, i’m blocked too.

I’ve installed phpmyadmin and roundcube with the script, and i can’t access it, 403 forbidden or 500 internal error if i delete my .htaccess, i’ve saerch on the virtualhost - put allow form all for the folder and directories but no way!!!

  • Emilien

I am facing same issue with Virtualmin GPL on Centos 7.1. Some time it’ allow me to logon to phpmyadmin but it showing me below error on PHPmyAdmin interface.

error in processing request error code 403

I am able to see databases there but unfortunately nothing loading properly.
I checked the permissions and those are ok for virtualserver user.

phpmyadmin is installed under /home/user/public_hhtml/phpmyadmin/

Please advise.

Like many things, not everything works out of the box, so sometimes you have to look outside the box.

Do you need phpmyadmin?

You probably do if you are selling hosting and your clients want it, but if not and you just want it for yourself, your in luck, use sqlbuddy

It is simple and works and I have a love for things that are simple and work…