PHP7.0-FPM failure after upgrade to 6.07

I’ve just installed the virtualmin, webmin and usermin upgrades posted today on a Debian 9 system using PHP7.0-FPM for all sites, and they have all stopped working.

I did the upgrade by:
sudo aptitude upgrade

and those were the only packages that have changed. (no standard Debian packages to upgrade)

My apache2 error log file contains pairs of entries like this:

[proxy_fcgi:error] [pid 23283:tid 140561914713856] [client 2a02:8010:6315:0:7433:f2a:a4f6:d8c9:36916] AH01079: failed to make connection to backend: localhost
[proxy:error] [pid 26583:tid 140687131494144] (111)Connection refused: AH00957: FCGI: attempt to connect to (*) failed

I’m not hugely experienced with FPM and don’t know where to start. Any ideas?

Update: panic over!

The listen port numbers in /etc/apache2/modules-available and in /etc/php/7.0/fpm/pool.d didn’t match up. Probably because I had edited the FPM pool files and Virtualmin didn’t want to touch them, but after a tedious manual editing session all is well now.

same problem but if you do the virtualmin config check it complains about php-fpm ports misconfig and messes everything up by screwing all the ports in the php pool

I’m on Debian 10 with php7.3

for now I had to hand change all the ports one by one in the /etc/php/7.3/fpm/pool.d/.conf
I also tried to set the same ports in the /etc/webmin/virtualserver/domains/
configs without luck

every time the virtualmin re-check config starts the ports are changed in the php pool and nothing works

I had to hand change all the ports one by one in the /etc/php/7.3/fpm/pool.d/.conf
Yes, That's exactly what I did.

I hadn’t got as far as looking at /etc/webmin/virtualserver/domains/ but it’s disappointing that you can’t get predictable behaviour that way either.

I'm on Debian 10 with php7.3
As a matter of interest, did you have problems or need to change anything to make current Virtualmin work on Debian 10 (compared with Debian 9) ?
I have a customer running Joomla! which is complaining that PHP7.0 is out of date. Technically true but with all Debian's security fixes it's actually safe, but even so it's disconcerting to have to tell him to ignore Joomla's warning.

I am running without problems Apache, Dovecot, Postfix and various other services without problem. As a matter of fact even php didn’t had problems until I re-checked virtualmin config.
The only thing that I had to do is to rename the /etc/php/7.3 into /etc/php/7.0 to made it work.
You might also want to delete all the php7.0* packages.

But since you need to re-check config in order to make virtualmin recognize 7.3 I won’t suggest upgrading until everything is fixed.
BTW I was on webmin 1.920 and virtualmin 6.06 when I made the switch.

I had same problem. I’ve rollback to 6.05 which is working and I got etckeeper which helped me to solve the issue.

Yep, I had same issue last night… I think I’m going back to FCGID and will let FPM mature a while longer.

The solution (workaround) is to change all domains to FCGID and back to FPM:

Step 1:

mkdir /var/run/php
chown -R www-data:www-data /var/run/php
/usr/sbin/virtualmin modify-web --all-domains --mode fcgid
/etc/init.d/apache2 restart
/etc/init.d/php7.0-fpm restart

Step 2:

mkdir /var/run/php
chown -R www-data:www-data /var/run/php
/usr/sbin/virtualmin modify-web --all-domains --mode fpm
/etc/init.d/apache2 restart
/etc/init.d/php7.0-fpm restart

(you might need to adjust the init.d lines, per your configuration)

I’ve found out that iptables dives a warning because of iptables-legacy
Does not broke anything and can be fixed easily (I think)

Ah yes, nftables is the default in Debian 10. I’d quite like to be using that; I wonder if Virtualmin will support it.

1 Like

In my case webmin is changing in all /etc/php5/fpm/pool.d/*.conf files the value of listen directive from socket to port.
Tested with “dpk-reconfigure webmin” and using “System settings -> re-check configuration” from virtualmin. The change is made without asking for confirmation

The following PHP-FPM versions are available on this system : 5.6.33 5.6.33 5.6.33 Fixing port clash for PHP-FPM version 5.6.33 Fixing port clash for PHP-FPM version 5.6.33 Restarting PHP-FPM server .. .. done Fixing port clash for PHP-FPM version 5.6.33 Fixing port clash for PHP-FPM version 5.6.33 Restarting PHP-FPM server .. .. done

i only knows if using ports before there was a bug and you have to do some manual changes to have it work.

Didn’t update while waiting for reply’s about this from support?

those 3:

I have the same problem with it. Any fix for that?

No doubt, that’s the bug.

Changing all websites to fastcgi and back to fpm can fix the problem, but won’t fix the bug.

That helps as a charm:

mkdir /var/run/php
chown -R www-data:www-data /var/run/php
/usr/sbin/virtualmin modify-web --all-domains --mode fcgid
/etc/init.d/apache2 restart
/etc/init.d/php7.2-fpm restart

mkdir /var/run/php
chown -R www-data:www-data /var/run/php
/usr/sbin/virtualmin modify-web --all-domains --mode fpm
/etc/init.d/apache2 restart
/etc/init.d/php7.2-fpm restart

Once a week, Saturday, 24.00 all websites go down. Something in Cron, but I cannot recognise what. This problem is after the last upgrade. Only above coffee can help…

Had anyone got the same problem?

Check if it is with / on graceful restart, of yes try to change to normal restart workarround for the time beeing

Apache restart don’t send all websites down, it must be something else…

I recon it’s a check configuration script. How can I check the Cron for that?

Btw. If I press check configuration manually in latest Virtualmin version, all websites go down…

Check not the restart but graceful we had that with a problem bug in apache part once then the cron changed from graceful to restart solved.

long long ago don’t know where to look.
some info about

And some has solved to build a “wait” in script somewhere

same problem. subscribing

Just updated webmin+usermin and now FPM is fu**ed up again. Since several versions and months, the autors of this so far beautiful software can’t seem to fix it or they just don’t care.


I’ve just done the update too, with the same result. One again I edited files to make the port numbers match in /etc/apache2/sites-available/* and /etc/php/7.0/fpm/pool.d/* and all sites are working now.

I thought I saw a promise that this would be fixed soon, but the recent security upgrade is arguably more urgent, so maybe that had to be done first.