Php5.6,Phpmyadmin,MBSTRING,500 Error...

LOL, Ya, Ok SO I upgraded to PHP 5.6 from the Original Centos 7 Server Clean (minimal) install, All went well, Well Had a Database issue I needed to check on, So in my Infinite wisdom said HEY, might as well Upgrade me PHPMYADMIN while I’m at IT, WOOOOPPPSSS!!!

Ok, So, Did that, Clicked the cool little link in the install script, got a 500 Error, Checked Directory/File Permissions (Quickly) all looked good, After searching around for an hour, I decided to revert to the old (stable) version (That worked fine before and after PHP Upgrade), and got:

phpMyAdmin - Error The mbstring extension is missing. Please check your PHP configuration.

So Figuring adding a php.ini extension would be the simplest solution, I did it Globally in Virtualmin, and locally in the Domain, No Good, Checked my phpinfo, and mbstring is not loaded, and on a YUM INSTALL No File found, nothing to do. The Install Script for the Revert to 4.4.5 gave this:

nstalling package php56-php-mcrypt …
Installing package(s) with command /bin/yum -y install php56-php-mcrypt …
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirror.pregi.net
  • extras: mirror.pregi.net
  • updates: mirror.pregi.net
    No package php56-php-mcrypt available.
    Error: Nothing to do
    … install failed!
    Installing package php56-mcrypt …
    Installing package(s) with command /bin/yum -y install php56-mcrypt …

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

this: https://www.softwarecollections.org/repos/remi/php56more/epel-7-x86_64/more-php56-php-extras-5.6.5-2.remi/

SO, Before I go installing stuff, and possible messing something up, as The old version (stable) of Phpmyadmin worked fine before I went to the “latest” version, I’m Assuming it’s something in the php.ini file that changed… I did a diff between the 2 files (etc/{USERNAME}/etc/php(s)/ and the only changes are the ones I made…

diff php5/php.ini /php5.6/php.ini

672c672
< post_max_size = 120M

post_max_size = 8M
800c800
< upload_max_filesize = 100M


upload_max_filesize = 2M
846c846
< ;


extension=php_mbstring.so <- Changed from .DLL!?!??!?!?!??! WIndows?

I also noticed in my phpinfo the Extension directory is:

extension_dir /opt/rh/rh-php56/root/usr/lib64/php/modules /opt/rh/rh-php56/root/usr/lib64/php/modules

So I guess the basic question is SHOULD I install the MBSTRING from the above repo?? Should I change the Extension Dir, I really don’t want to go Mucking around with Guesses, I usually end up doing a complete ree-install when I do…

SO at the Moment I cant revert to PhpmyAdmin and at the moment, need it…

Sorry if this was confusing, got about 2.5 Hours worth of searches in my brain…

AND Most said, Add The Extension to php.ini, OR install mbstring… WHich is obvious but just need to make sure I SHOULD…

Thanks for any ideas.

Mike

EDIT: Man I screwed that whole post up, It’s MBSTRING that seems to be the issue, and that link doesn’t have it (I believe)

EDIT: Ok I found my Confusion, MCRYPT is in the repository linked above, and it’s trying to Install the 5.6 version in the script (and on the server), and the same with MBSTRING, But the files aren’t in the REPO, and MCRYPT is in the link above, so the question should I install it from that link.

On reading, It is NOT recommended to Install Anything not directly supported by CentOs :https://wiki.centos.org/FAQ/General#head-472ce8446ebcfc82ca1800f775ba0e629ac835c7

Ok Guess I found a FIX!!! I went back to PHP 5.4 and Re-installed PHPMYADMIN 5.4… Until there is a further update I guess…

Howdy,

Glad to hear things are working with PHP 5.4!

It’s probably fine to install the PHP extension from the link you shared, but if you’re able to use phpMyAdmin with PHP 5.4, that certainly simplifies things.

-Eric

Yes with things working so well, and me still learning the Ins & outs, Best to leave it be tell someone with better knowledge gets it working, No real big deal, I wanted to Upgrade PHP thinking some forum errors I was having… But the upgrade didn’t change anything, so leaving it is the best and safest plan.

Nike