php4 to php5

Hi There,

I am trying to change the default php version from 4 to 5 in one of my virtual server, but after I had saved the change (sucessfuly), I access again the very same option and it still showing me that the default php version is 4.

On the other hand, If I try to change the default php version to 5 at the Server Templates Option I get an error message saying:
"Failed to save server template : Missing or invalid Apache user"

Any idea on how to fix it?

BTW, is there any option where I could disable/uninstall completely the php4 in my entire server / settings?

Thank you,<br><br>Post edited by: Renato, at: 2007/09/13 05:39


If you have the same problem,
(according to Jamie it is a bug and will
be fixed in the next release)…

You have to access /etc/apache2/sites-availables
and look for <yourdomain>.conf file

change the line:
FCGIWrapper /home/<your usename>/fcgi-bin/php4.fcgi .php

FCGIWrapper /home/<your usename>/fcgi-bin/php5.fcgi .php

any ideas when it will work again?

New version is coming out within the next couple of hours.


Thank you,