php upgrading from 5.3.10-1ubuntu2ppa6~lucid to 5.3.2-1ubuntu4.21

I am using 4.00.gpl GPL
Ubuntu Linux 10.04.4
Linux 3.9.3-x86-linode52 on i686

for Tinymce I need to use

apt-get install php5-pspell

but get this error

php5-pspell: Depends: php5-common (= 5.3.2-1ubuntu4.21) but 5.3.10-1ubuntu2ppa6~lucid is to be installed
E: Broken packages


what is the best way to upgrade php to this level in virtualmin without breaking anything much ?

many thanks in advance


It looks as if there are some non-standard PHP packages installed, which came from a third party repository (a PPA in this case). Those are causing dependency problems when trying to pull in new packages.

My suggestion is to disable the third party repository, and to then install the main Ubuntu PHP packages, which will resolve the dependency issues you’re seeing there.

Alternatively, you could always see if the PPA repository that your current PHP packages came from have the php5-pspell package you need. But we always recommend sticking with the distribution-supplied packages :slight_smile: