PHP Problem

Hi!

I’m having a problem with php:

I’m not sure why, but suddenly php doesnt seem to work any more… When I try to access my websites in the Browser, it just prompts me to download the php-file instead of executing it. The settings seem ok, what could be the reason for this? Where can I look for the reason?

I installed the latest updates for apache, since then it doesn’t seem to work…

Please help a desperate newbie!!

Howdy,

Take a peek at the error logs, in both $HOME/logs/error_log as well as in /var/log (where exactly depend on your distro). Do you see any errors?

Also, is this Virtualmin GPL or Pro? They have different defaults, as to whether they’re using mod_php, suexec, and such.

-Eric

Thanks for the fast reaction!

The $HOME/logs/error_log files of all my domains and subdomains are empty…

I’m using Virtualmin GPL

I’m thinking about uninstalling virtualmin with install.sh and then reinstalling it and configuring everythin from scratch, but this would be a lot of work…

I just looked into the apache modules configuration in webmin, id said on php5 - disabled. When I try to enable it I get an error on the apache-start:

Starting web server: apache2apache2: Syntax error on line 185 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
failed!

I can only start apache with php5 disabled…

I already tried reistalling php5 and apache2 manually from the shell, but the problem remains…

Edit:
I just looked into the directory and the file libphp5.so really doesnt exist…

i just managed to uninstall php5 and the reinstall it. The file is now there, apache starts, php5 is activated, but it still wants to download php-files…

And its just the virtual servers that dont work.
when i access the standard-URL that was given to me by the ISP (http://760.hostserv.eu/), php works just fine…

Did you see any errors in the system-wide error log – in either /var/log/httpd/error_log, or /var/log/apache2/error_log?

-Eric

Hmm, the strangest thing! I just clicked around a bit, tried to create testservers, and deleted them again and suddenly everything seems to work again… At first, mySQL didn’t seem to get connected, but after a restart of the mySQL-Server, everything is OK.
I hope that this wont happen again, since i’m starting to have my friends’ webpages on my server very soon…

Huh, well, that’s odd… but I’m glad it’s working now :slight_smile:

Yeah, it for some reason it happens again, let us know, and we’ll try and work out what’s going awry!

-Eric