Php not working/loading/parsing on single virtual server 500 error

2 days of troubleshooting and I am out of ideas and articles to follow…

I have 1 virtual server that I migrated from cpanel (like the 6 I did before) and all have run fine except this one. Some are wordpress some are not. This one is a wordpress but that issue aside, to troubleshoot I wiped the public_html folder and the issues persist.

When I try to load any php files I get a 500 error. html loads just fine.

I have scoured the internet regarding permissions, php settings, directories, execution method, etc, etc. Nothing seems to fix this issue.

Right now I have 2 files: (should display current time) (has “…” html and string to show time)

I am running php 7.3 and also 7.0 - both have the same issue. Permissions all check out in vm. Re-check configuration is good overall.

OH and error log only says this over and over:
(104)Connection reset by peer: [client] mod_fcgid: error reading data from FastCGI server
[Tue Jul 14 15:32:37.742212 2020] [core:error] [pid 21293] [client xxxxx:xxxxx] End of script output before headers: phpinfo.php

Please for the love of God, I need help.

I had this problem along time ago and this link saved me. I can’t point the solution per se but I bookmarked it as “500 FASTGCI ERROR”

Also you must service httpd restart

Hey thanks for the reply? What link?

Sadly, I’ve pretty much tried all that, and what I hadnt, now that I’ve tried it, didnt help. Most of it doesn’t apply anyways, as globally everything is working great. Just this one virtual server doesnt seem to be parsing php.

Are you using short tags?

Try a PHP page with something like:

<!DOCTYPE html>


echo("Hello, World!");


And see if that works.


Yes unfortunately thats essentially what my test.php link has. I put your exact code in there instead just in case and still get 500 error.

I’m assuming you checked .htaccess in the site’s root directory for any wonky crap that cPanel may have placed there?

It actually didnt have one while it was working correctly on the last server BUT I’ve also tried a default one and blank one. Again, I have currently removed the wordpress install all together with just the two test files/links listed above. I would simply delete and reinstall this vs but the customer has a ton of email which complicates it.

Have you looked at ? It’s old, but might provide a clue or two.

Hey thanks for the continued help. Unfortunately, that didn’t work :/.

This is insane. Every other virtual server works perfectly from start as expected. I don’t even know what else I could check that isnt setup just like everyother vs.

I just imported this site like every other, but on this one php wont run. It’s nuts.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.