PHP not applying configuration


On a system running Debian 10, using Nginx version 1.14.2 , and 3 versions of PHP.

I’m running two virtual servers on this machine for the moment.

I wanted to increase the allowed PHP size on one of these virtual servers.
Its config file is stored here /home/hero/etc/php7.4/php.ini

So in Virtualmin => Services => PHP 7.4 Configuration => Resource Limits
which lists /home/hero/etc/php7.4/php.ini as the target file, I increased the “Maximum file upload size” value.

However , when hitting the save button it doesn’t not apply, I have to reboot the whole server for it to work.

Any idea what I could be doing wrong?


Does it work by just restarting PHP-FPM?

systemctl restart php7.4-fpm.service

Hello ! No it doesn’t :frowning:
For example right now in my virtual server’s admin interface I have set this:

However, after running the command to restart the service, if I access a PHP Info on this virtual server I get a different value for upload_max_filesize


Try Virtualmin → Services → PHP Configuration: Resource Limits

Note that this will apply only to the currently selected virtual server, not globally.

thanks @calport that’s precisely where I make my setting (see my previous screenshot) however my problem is that it doesn’t apply until I reboot the whole server for a reason that I’m trying to figure out :frowning:

The reason that the settings apply on reboot and not via the following…:

…is because the above command restarts php-fpm but you are using FCGId (run as virtual server owner). If you restart PHP from the cli, you will not have to reboot.

As soon as I read “Nginx” I assumed PHP-FPM.

Oh right thanks guys. I dont know what if I screwed up or anything when I installed my server haha… Maybe I went with the default config on that matter.

Do you think I should switch to PHP-FPM for a better integration in Virtualmin (like … applying settings without using the CLI) ?

Have a good weekend and thanks for your reactiveness and help

Nginx without PHP-FPM is kinda like peas without carrots. It’s getting to be that way for Apache too. If you ran the Virtualmin install script with --bundle LEMP I would think you would have ended up with PHP-FPM but I don’t know this for a fact.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.