PHP mkdir and fileopen are not working in domain

I have a strange one here…

I am on a CentOS 6 64bit apache 2+ php 5.3.8 and mysql 5.7+ machine with 2tb drive so no space issues. My dns is via cloudflare free plan and minify has been disabled.

I cannot get mkdir to create a directory nor fileopen to create a file from within a php file in the domain.

I am not running suPHP or anything like that i am just running mod_php and letting apache do the job.

I have tried permissions up to and including 777
i have tried adding apache as a second group for the username
i have tried rebooting
i have tried testing with is_writable and none of the folders are writable not even as 777
I have tried apache:apache owner:owner and root:root
i have turned safe_mode off even though it has been removed
i went to the command line as both the username and as root, and in both i can use mkdir no problem at all, i just cant do it via php file in the domain
I have disabled suhosin and verified that it has been disabled via php info
I can do phpinfo and phpversion from the php file so php is there

I did attempt to install suPHP and use suEXEC and mod_fcgid but i gave up it was just too complicated. Im back to just mod_php and i have actually uninstalled mod_fcgid to be sure its not a conflict. The settings in virtualmin are set back to no on cgi and apache on php.

There are no errors in the local log and no errors in the server log. However i may not actually be getting errors to be honest as i noticed when i have a typo in the php the page just crashes rather than give me an error and i have all the error triggers set to on and log, so im not sure if its related or not.

what else can i try or what else should i look at to figure this out?

any ideas, thanks :slight_smile: