php.log is logging weird sutff


I have virtualmin installed in a server with nginx and varnish. I created a new server to add a new website. Everything went well, but I noticed that after a while the php.log was huge, close to a GB. Then when I opened the file, I could only see the following repeated over and over:

Usage: php5 [options] [-f] [--] [args...] php5 [options] -r [--] [args...] php5 [options] [-B ] -R [-E ] [--] [args...] php5 [options] [-B ] -F [-E ] [--] [args...] php5 [options] -- [args...] php5 [options] -a

-a Run as interactive shell
-c | Look for php.ini file in this directory
-n No php.ini file will be used
-d foo[=bar] Define INI entry foo with value ‘bar’
-e Generate extended information for debugger/profiler
-f Parse and execute .
-h This help
-i PHP information
-l Syntax check only (lint)
-m Show compiled in modules

… and the rest of the help message.

I was wondering, does anyone know why is it logging that and how to stop it?



Any help would be appreciated, I am sure this is a straightforward fix I just dont seem to be able to figure it out.

I realize this is an old post, but I’ve searched a lot, and this was the only thing that came up.

I’m having the same issue - php.log files containing only output of “php -h” repeating many, many times.
Some of them were in the range of gigs when I found them (was wondering why my backup spaces were getting filled).

Any fixes / ideas?

Debian Linux 8
Webmin version 1.760
Virtualmin version 4.18.gpl
Kernel Linux 3.16.0-4-amd64 on x86_64

This happened to me. In my situation, I had php-fpm set up, but virtualmin would auto-setup php-cgi. I forgot to disable that PHP version, so it was turned on, like so:

Turning that off fixed it for me.