PHP Issue After upgrade

I had posted an issue after the VM update before the most the most recent one. At that time my issue was I had a site that had some php code in an asp file. To get that to work, there was an htaccess file that used: “AddType application/x-httpd-php .asp”. After the previous VM update that line no longer worked and I fixed it by using: “AddHandler php5-script .php .asp” instead.

Yesterday I updated again to the newest VM version and now the php code (like before) is being automatically comment out.

If someone could offer a suggestion on how to now get this php code parsed I’d appreciate it,



It sounds like that may be relying on mod_php to function.

If you change your domain’s PHP Execution Type to “mod_php”, does it function correctly at that point?

You can change that in Server Configuration -> Website Options.


Thanks Eric, ya know, I could have sworn I did that as my first test - but before I told you I had already tried that, I did it “again” and it worked.

So THANKS again. Is the site at risk now?


Well, it’s no more at risk than it was previously :slight_smile:

But yes, that particular site appears to need mod_php enabled to function, and that does introduce security problems on multi-user systems.

It doesn’t make that one site at risk, that makes your other sites at risk from that one site.


Ah, I see - it’s been this way for a few years, so I guess I won’t sweat it.

Is there any better way of doing this now?

I just got another customer, this one with php in html files and had to switch over to mod_php to get to work. This one is a rather busy site and I’m not feeling real comfortable with the security compromise.