PHP-FPM pm.max_children defaults to 9999

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Webmin version 1.999
Virtualmin version 7.1-1

I’ve read: PHP-FPM defaults to pm.max_children = 9999! How to globally set sane value for all existing virtual servers

It looks like this issue is supposed to be resolved, but my PHP-FPM virtual servers are still defaulting to pm.max_children = 9999 in /etc/php/7.4/fpm/pool.d/xxxxx.conf

Is there any template file or config variable I need to change?

Thanks

Hello,

Yes, it can be configured globally on Server Configuration ⇾ PHP Options: Edit Server Template page with Additional FPM pool options field or locally on virtual-server.name - Server Configuration ⇾ PHP Options page.

Although, I see that it’s still not displayed on PHP Options page in some cases. We will fix that. Meanwhile, try to fix it manually on virtual-server.name - Services ⇾ PHP-FPM Configuration: Manage PHP Configuration page (by editing configuration manually).

1 Like

Also see

Excellent, thank you @Ilia and @calport.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.