PHP-FPM PHP7.2 cURL PHP extension and Memcached

Virtualmin installed php5 and php7.2 when you do php -v php5 is listed. A site is configured for FPM7.2 and works well but cURL php extension is not loading. How can I add this module using php-fpm 7.2? I have been googling for ages and all I can find is the normal php.ini etc. non related to php-fpm.

When I re check config:
The following PHP versions are available : 5.4.45 (/bin/php-cgi), 7.2.24 (/opt/rh/rh-php72/root/usr/bin/php-cgi), 5.4 (mod_php)

The following PHP-FPM versions are available on this system : 5.4.45 (php-fpm) 7.2.24 (rh-php72-php-fpm)

curl is listed under modules but not loading? Its detecting old curl version I think. I tried to upgrade and it did upgrade but curl is still listed as the old version.

Anybody who can help?

Edit - after doing xx stuff, somehow I managed to get it updated to curl 7.57.0

How can I add Memcached to load using PHP-FPM?

You need to at least install php-memcached and restart the apache2 after that. I am not sure, but I think you need to install memcached too. You can set the configuration in the memcached.conf and I think its located in /etc.

memcached been installed and actually running but php-fpm is not seeing it/picking it up as my invision board cannot see it/ pick it up. php-fpm is not seeing the config.

Did you restart php-fpm after that? Is php-cli installed too?
Did you enable the memcached service? Try to run systemctl enable memcached.servic
And did you take a look at the memcached.conf?

yep, did all that and php-cli. hwn checking status it looks good:
memcached.service - Memcached
Loaded: loaded (/usr/lib/systemd/system/memcached.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2020-04-27 14:47:59 CEST; 3min 45s ago
Main PID: 20515 (memcached)
CGroup: /system.slice/memcached.service
└─20515 /usr/bin/memcached -u memcached -p 11211 -m 4GB -c 1024

Just that php-fpm 7.2 cant see it nor can my ipboard. I restarted php/fpm and apache. I have to google some more grin

maybe your os is having a php72-memcached package? cause it seems default is php5…

I installed php7.3 changed site to use mod-apache. memcached then became visible. rebooted server and php-fpm started. i changed site back to php-fpm but it kept the memcached setting, for now anyway.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.