Php-fpm cannot find gid for group ''

Operating system: Ubuntu
OS version: 18.04

I’m trying to switch one domain to php-fpm from php-fcgi but it crashes with error

ERROR: [pool 157509028816584] cannot get gid for group 'domain'

This domain used to be a virtual server but was later made a sub server under another one. I checked /etc/webmin/virtual-server/domains/157509028816584 and ugroup was set to domain. I changed it to the user of the parent server. Maybe similar to this issue

I also checked /etc/php/7.2/fpm/157509028816584.conf but this file doesn’t exist.

php-fpm is still not able to start. Its the same error. Where is it getting the group name ‘domain’ from? Are there any other locations I should be looking at?

You can try to check the group file:

less /etc/group

And/or use the “id” or “groups” command to check for it.
And if php encounters and issue while switching, then it is pretty much normal that it doesn’t create the necessary configs (as far as I remember).

group file looks ok. Can you tell me what the commands are? Or a link where I can read up on it?

I did in the first post.
Not the best site, but it got some examples:

Other than that, it sounds like you should read about log files and how to properly read them. Please don’t take this the wrong way.

Thanks for the links. They returned “no user” for this. However, I rebooted the server and for some reason I was then able to switch it to FPM. Not sure why that worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.