php-fpm and proxypass


I noticed that now we can configure virtualmin to use php-fpm without having to do it by myself, that’s great, but I noticed you used: ProxyPassMatch
I had an issue few months ago with that, where it would crash when trying to load some php scripts, instead, it was recommended to use:

ProxyPass ...

I’ll try to see if that happens again, but sadly I don’t remember where I had the issue.

Also, when I select php-fpm for the server, I can’t select php version anymore, the error is because the server is using mod_php, which obviously I’m not.

“trying to load some php scripts” ? just your sensation…or something wrong. Never happened because it’s not an issue…
the problem may be somewhere else, instead.
Eg. they confused pm.max_children in place of pm.max_requests
setting max_children too high, that’s insane and may crash the server for sure…
ProxyPassMatch has nothing to do with the crash