php fpm 7.2 not working

I have a fresh install of virtualmin on debian 9. I’d like to use php fpm
First I tried php 7.0 which was automatically installed by virtualmin, and it worked fine.
Then tried to upgrade to php 7.2, so I removed php and php-fpm 7.0 as it was suggested in other posts, and installed version 7.2
When I re-run configuration check it says :
The following PHP versions are available : 7.2.12 (/usr/bin/php-cgi7.2)
PHP-FPM version 7.0 support is available on this system.

And when I create a virtual server I can’t view my website, and I have this error in apache error log :
[Mon Nov 19 09:09:19.860680 2018] [proxy:error] [pid 32650] (111)Connection refused: AH00957: FCGI: attempt to connect to (*) failed
[Mon Nov 19 09:09:19.860787 2018] [proxy_fcgi:error] [pid 32650] [client] AH01079: failed to make connection to backend: localhost


I replaced fcgi://localhost:8000 by fcgi:///var/run/154262472926263.sock
In my apache conf file, but now I have this error

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /index.php.

Reason: DNS lookup failure for:

I don’t have this error when I don’t use php fpm


I have the same error, did you get to fix it? How?

Thank you

Here is what I did :

Edit /etc/php/7.2/fpm/pool.d

user = domainname
group = domainname
listen = /var/run/php/domainname.sock
listen.owner = www-data = www-data
pm = dynamic

Edit /etc/apache2/sites-available/domainname.conf

<FilesMatch .php$>
SetHandler “proxy:unix:/var/run/php/domainename.sock|fcgi://localhost/”

same problem. subscribing

I posted a solution, it does not work for you ? What’s the error ?