Permissions in the mail system error

SYSTEM INFORMATION
OS type and version Debian Linux 10
Webmin version 2.001
Usermin version 1.860

I have a problem in Usermin and in all the emails of all the VirtualHost.
It is not possible to delete the messages or do practically anything with them from Usermin, nor from Roundcube installed in …/mail
The logs from /var/log/mail.err say: Jan 4 10:00:28 dos dovecot: imap(ruralesenredadxs)<26738><1w55amzxGIF/AAAB>: Error: Mailbox INBOX: rename(/home/webs/ruralesenredadxs/Maildir/new/1666174529.6677_0.dos.texu.es, /home/webs/ruralesenredadxs/Maildir/cur/1666174529.6677_0.dos.texu.es:2,) failed:Read-only file system
I try to change the permissions of the Maildir folder, but it’s still the same… messages cannot be deleted, it seems to receive emails fine and although Usermin gives an error when sending email messages, in the end it does send them, at least In the tests I have done this morning…

Are quotas full? Read only filesystem error is not permissions…that’s what happens when the disk or the quota is full.

Note also that the domain has a group quota on top of the mail user quota, either one can be full and this will happen.

I know you’re trying to delete a message, but that involves writing, too.

I don’t get it, there is something wrong here…
The disk usage is:
/ ext4 57% (15.57 GiB) 27.33 GiB
/boot ext2 78% (362.87 MiB) 469.35 MiB
/home ext4 94% (436.73 GiB) 468.9 GiB
therefore there is enough free space
Same error right now:
dovecot: imap(web@texu.es)<30771>: Error: Mailbox INBOX: rename(/home/webs/texu/homes/web/Maildir/new/1672416852.6399_0.dos.texu.es, /home /webs/texu/homes/web/Maildir/cur/1672416852.6399_0.dos.texu.es:2,) failed: Read-only file system
This error corresponds to the email address: web@texu.es which has used space: 784 KiB unlimited…
As I see the quotas are fine from Virtualmin
Where should I look to see this possibility in the group quotas, because in the user quotas they are fine, apparently clear

It may not be quotas. But something is telling Dovecot the filesystem is unwritable.

In the Virtual Server Summary, there is a Total server quota field, and also in the Dashboard, there is a quota summary of all domain accounts.

Obviously if they are set to unlimited, something else is wrong. But I’m not sure what. “Read-only filesystem” means exactly what it says. It’s either been mounted read only, quotas for the user are full, or something else is going wrong.

Can any user delete a message or is it specific to this one?

I think the problem could be that when I change the physical server and mount the proxmox and I made a VM for Virtualmin I change the hostname in /etc/hosts when I restore the Virtual Servers in Virtualmin…
So I changed the hostname to the old one and now I can delete the mails in Usermin…
I’m going to keep testing things just in case there is something wrong configured… that’s why I’ll put this ticket on standby before closing it, just in case.
Thanks for everything.