permission file 666 don't execcute

I have a problem that I can not solve, in the panel virtualmin can set permissions subdirectories as I like, so those are ok, while the files AFTER AVERLI CARICATI through proftpd I can not give him rights escuione automatically, maximum I give him 666 while me that I would like them caricasse to 777, in practice I can not give him all the permits.

holetto around that the value umask for files beginning at 666 and not 777 as folders.

how can I do? there is a point where virtualmin can set the permessididefault for files as directories?

If I can help there would be grateful.
I can not solve.

thanks to all.

in virtualmin-system settings-server template-click default settings-navigate to apache website- there is "Permissions on website subdirectory"

there is also webmin-servers-proftpserver-and in the edit config files is a line

Umask 022 is a good standard umask to prevent new dirs and files

from being group and world writable.

Umask 022

per haps this will work?

This forum is for hosting providers to post there sites.

The help forum is the Virtualmin one. Let’s try to keep on topic for each of the forums please.

excusme but my english is not good and i don’t understand all.


ok but the permessei files I remain at a maximum of 666 or I want them to 777.
how can I do?
for folders ok.

If you don’t understand english then you are in a load of trouble – it’s all we use here and if you can’t read/understand english then why are you asking in english? Pointless isn’t it?