perl modules

Hi, I have attempted to install the webclamav webmin module so as to manage clamav. That seems to have gone ok as the clamav comes up under system. Now when I click the link I get the following:

Please, install the following perl modules from the Webmin CPAN module or download them directly from the CPAN web site and install them manually (read wbmclamav README file for this) in order to use this application:

Mail::Mbox::MessageParser

Problem is when I go to instal the perl module nothing happens I get;

Installing Perl module Mail::Mbox::MessageParser from package perl(Mail::Mbox::MessageParser) …

Installing package(s) with command yum -y install perl(Mail::Mbox::MessageParser) ..

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos-mirror.jchost.net
 * extras: mirror.steadfast.net
 * updates: mirror.cisp.com
Setting up Install Process
No package perl(Mail::Mbox::MessageParser) available.
Error: Nothing to do

.. install failed!

Some modules failed to install from packages, trying installation from source instead…

Downloading http://www.cpan.org/authors/id/D/DC/DCOPPIT/Mail-Mbox-MessageParser-1.5002.tar.gz (260.12 kB) …
Received 1024 bytes (0 %)
Received 27 kB (10 %)
Received 53 kB (20 %)
Received 79 kB (30 %)
Received 105 kB (40 %)
Received 131 kB (50 %)
Received 157 kB (60 %)
Received 183 kB (70 %)
Received 209 kB (80 %)
Received 235 kB (90 %)
Received 260.12 kB (100 %)
… download complete.

and then it seems to hang

have even tried downloading from cpan to my computer and uploading it but still get the same.

Can anyone help?

Howdy,

Hmm, I’m not sure why that isn’t working – it’s possible that it’s prompting for some kind of information that Webmin isn’t able to handle.

You may want to try installing that module from the command line to see if that works, or perhaps to see what it’s doing when attempting to install.

You can install that module from the command line by running this command as root:

cpan -i Mail::Mbox::MessageParser

hey i am gettingthe same error please help

Warning: No success on command[/usr/bin/perl Makefile.PL]
YAML not installed, will not store persistent state
DCOPPIT/Mail-Mbox-MessageParser-1.5105.tar.gz