Password change and now I'm locked out

Guys, what’s the secret to changing the password and being able to log back in?
I’ve tried changing the password in Webmin/Change password, also with passwd in shell and still can’t log in. Rebooted server, rebooted Webmin and nothing.

C7Operating system:
OS version:

Are you sure the password change took? Have you tried the old password? Are you logging in as user or root? Which password did you change, user or root?

I changed the root password

It doesn’t matter what I do. It won’t let me login

This CP is very unstable.

What OS are you using?

And what CP are you saying is unstable? You’re not making much sense. How did you change the root password: from terminal or did you try to change the root password in Virtualmin?

You’re not really saying anything about what you’re using or how you did it.

I’ve tried changing the password in Webmin/Change password, also with passwd in shell and still can’t

In terminal and still doesn’t work… I can’t be the only one with issues with Webmin

I’ve never heard of C7 other than a Samsung phone so I have no idea.

1 Like

Os is CENTOS 7…

I just logged in through Putty, changed the root password and still Webmin won’t let me login. I cleared Cache and nothing.

Ah. Now that I know. There’s an old work around for that I’m pretty sure still works. Go here and follow the directions.

Hang on a second. You can log in to CentOS7 but not Webmin?

yes. that’s the issue

Can I add another user to Webmin through Terminal?

Have you tried this:

  • How do I change my Webmin password if I can’t login?

Included with the Webmin distribution is a program called to solve precisely this problem. Assuming you have installed Webmin in /usr/libexec/webmin, you could change the password of the admin user to foo by running:

/usr/libexec/webmin/ /etc/webmin admin foo

Also, just for clarity: when you try to login to Webmin are you typing a user name or just the word “root”?

The word Root as always been.

There is no secret. It’s always worked fine for me.

It is possible to end up with two different passwords (one Webmin, one system), but that’s not the default; the default is to use system passwords. The command changes the Webmin password, while passwd changes the system password. If you previously used you may have two different passwords, so you’re perhaps you’re trying to login using the system password, which obviously wouldn’t work, since you’d have a non-system password for Webmin. I recommend just using one.

The Webmin->System->Change Passwords page modifies system passwords (not Webmin passwords). If you change there, and you’ve also set a Webmin password (using or the Webmin->Webmin Users module), you are not changing the password you use to login to Webmin.

Visit Webmin->Webmin->Webmin Users->root

Make sure it is set to “Unix Authentication” rather than anything else. Having two passwords is just confusing you, so don’t do that.

Thank you for the explanation Joe. That explains lots of things. I’ll look into it.