Package updates - up to date check wrong

Hi, thanks for this great product. Let me explain a little but annoying problem…

I have Virtualmin on Centos 5.5, I had a problem with this because, because was lacking of the unicode support: pcre-6.6-2.el5_1.7.x86_64.rpm

So i updated the package, using a recompiled version with unicode support, following this guide:

The new package name is: pcre-6.6-2.7.x86_64.rpm

Now it works correctly, but Virtualmin package updater think that it’s outdated, so I have this message in home page:

Package updates All Virtualmin packages are up to date.
1 updates to system packages are available. Use the Virtualmin Package Updates module to install them selectively.

There is a way to avoid this message?



Virtualmin doesn’t actually know anything about packages and versions – it just uses “yum” in order to determine if new packages are available.

So, using the repositories setup on your server, if yum determines that there are newer packages available, Virtualmin will pass that information along.

If you follow the link it provides to go into the Virtualmin Package Updates module – which packages is it saying need updating?

Now, before we get too far, I’ll offer that if yum says that there’s an update for pcre, that may mean you’re using an older pcre package version. That could imply that there’s bugs and/or security issues in the software version you’re using now. So, be careful using older packages :slight_smile:

That said – if you’re really sure you want to stick with the software version you have there, and there isn’t a simple way to update your custom RPM to a newer version – you could always edit the .repo file(s) in /etc/yum.repos.d, and setup an “excludepkgs” line to tell it not to attempt to update pcre.

That would look something like this:


Thank you for the answer.

Uhm, my package is not old, but is the original package recompiled (to have unicode support).

In fact, if I run “yum update” or “yum upgrade”, it does nothing, and also if I go to Webmin > Software Packages Updates, here it says “No packages available to be updated were found.”

This is because I think that only Virtualmin is doing a strange check… Are you sure it uses yum? How?

In fact 6.6-2.7 version is not older than 6.6-2.el5_1.7… but it depends on how the check is done!

I’m attaching screenshots:

  1. virtual package updater notice
  2. webmin “upgrade all fuction” that calls yum and find nothing to update
  3. webmin software updates module that say nothing to update