Package Update not working

Hello Everyone,

Ubuntu Server 20.04.6
Webmin version 2.102

Yesterday I got an alert that said 2 Packages needed updated, So naturally I went to my UI and tried to update them:

The above is what I saw, so I clicked update packages, then install packages. Below is the result I got when I tried to install:

Can anyone tell me how to fix this so they will install? I don’t think I have seen this before…

Thanks you very much,

Can’t cannot to repo for docker, this is not really a webmin issue.
Did you try the recommended commands at the end of the error.

Maybe the mirror is temporally down.

The docs for docker have a different repo.

Hello Stefan1959,

Sorry Stefan I actually did do an apt update and apt update --fix-missing as root on my server. Thank you for pointing it out though.


Do you remember what docs you used to install it?

Hello Stefan,
This is the guide I followed: NAS on a VM/RPi4 Device

It works perfectly, I didn’t install docker on this device because I didn’t know how or that it existed in Webmin. But now I am intrigued lol.

Thanks for your help,

I meant docker.
Docker is not a normal package to have. Weird its on your system.
Raspberry pi , nice.

Hello Stefan,

Just an FYI Docker and Kubernetes (MicroK8s) both work perfectly on RPi/OrangePi/RockPi as well as Proxmox (coined Pimox)

Pretty cool actually,
Thanks Again Sir,

1 Like

Ooops I now know why, I installed it on there for testing purposes with Webmin. My bad thanks,


Thanks for helping I just purged it.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.