Outlook refuses to add IMAP email, Windows 10 Mail auto configures IMAP perfectly

Can someone explain this to me…

When i try to configure an email account using Office 365 Outlook…

  1. Auto configure fails
  2. Manual configuration also fails (even though i copy the EXACT information from Thunderbird)

What makes this EXTREMELY frustrating,

Windows 10 Mail autoconfigures the new mail account in about 10 seconds flat!

Both programs are on the exact same Windows 10 PC

I cannot understand why Outlook for Office 365 client simply refuses to allow me to add a Virtualmin Virtual Server email account?

Some may say, let sleeping dogs lie and use the Windows Mail client…trouble is, i only have a Home subscription which doesn’t allow me to send group emails…so i have to use Outlook .

I suppose i can simply give up and just use Thunderbird which is working no problems, however, I am a stubborn F#$ker and i want to get this working (if i cant what chance do any of my clients have who may wish to use Outlook?)

Also if you try to manually config outlook? ( outlook is not thunderbird for the ports and tls you have to trie some and look in logs)
Also search forum websearch with the messages you get wen try outlook from outlook itself

Problems could be the tls version allowed if configured on your VMBOX

but that you could see in the maillogs in the VM, also other things if trying to setup outlook account manualy, then take a look in log files.

There is a GUI part in virtualmin for having user / mailuser ( something with dots and yes or no @ in it, that part is different at a VM box then some other CP’s)

Do some tests with your mailserver VM box as mxtoolbox online https://mxtoolbox.com/

I have worked out the problem…

My incoming and outgoing mail server username is in the format user.domain.com.

Outlook it appears, cannot use that format…it must be user@domain.com.

What a bummer. The only solution is to change the username format in virtualmin to user@domain.com. The problem is, last time i did that on an already functioning system with client accounts, i started having problems with mail server so im not keen to risk it again.

YUp it happens.
Hope you did read and understand my writing / answer above about that dot and @ ? :wink:

Don’t know about problems.
Is this not solved in the virtualmin GUI with kind of alias possible to set?

Otherwise the only problems i can imagine is that usernames already used changed and then firewall, fail2ban blocking . that clients…

These setting in GUI is under Webmin > servers > postfix mailserver > Address Rewriting and Masquerading
Address Rewriting and Masquerading
Rewrite “user%domain” to “user@domain” Yes No Rewrite “user” to “user@$mydomain” Yes No
Rewrite “user@host” to “user@host.$mydomain” Yes No Rewrite “site!user” to “user@site” Yes No

EDIT: Thinking the wrong way here maybe.

OUTLOOK does support with a dot username ( take care of difference between emailadres and username)

We have a box withworking @ and not the dot in username i don;t know anymore or this is because Address Rewriting and Masquerading set

PFF is late her sorry putting things …

better look here

Sorry, there unfortunately isn’t a simple way to convert existing users from one format to another.

Once they’re created they keep that username format.

Though one workaround to that which I think would work, is to generate a backup of a Virtual Server that contains usernames in the old format, and then to restore that backup.

Restoring that backup should cause the usernames to be created with the new format.

I am not able to find any means within the Outlook app to change the incoming and outgoing server credentials to allow user.domain.com. No matter what i do, Outlook automatically defaults to user@domain.com with no available option to customise it.

I have done a bit of searching around and I am not the only one who has had this problem with Outlook. What i simply cannot understand is why one can customise to user.domain.com with Windows 10 mail? (they are both microsoft products)

I might play around and reset the default incoming and outgoing credentials to user@domain.com again and see how it goes as this is clearly going to be a problem for any client mail accounts on my server if i dont sort it.


Note that because of the issue you described above, we’re actually planning to change the default username format to user@domain.tld on all new installations in Virtualmin 7.

It shouldn’t be a problem to switch to user@domain.tld though, but if you do see issues with that, take a peek in the email logs to see if there’s any sort of error that’s occurring.


Hi guys,

When I add a IMAP account to outlook or windows 10 mail I don’t enter the password at first, that brings the pop-up window with the form for username, password and “save password” checkbox, now I can change the user@domain.tld username format to user.domain and enter the password. This does the trick for me!


I never understood the reasons. I think it could expand if they allowed themselves to expand their means as other silver did