Outlook 2007 emails not delivered

Hi all

I am extremely new to Virtualmin and hope someone could help me on this one.

I have a dedicated server and have 3 websites on it. The OS is Ubuntu 8.10. All works well, but I cannot sent email from only one account. The other emails on the same domain is fine, but this one user is using Vista with Outlook 2007. When replying to an email, it works fine, but trying to sent email to new recipient, it’s not delivered. I also get the message that the certificate could not be verified.

I am not well skilled in these kind of things and had a fried installing this for me, he also do not know how to solve this one.

PLEASE help me.


Are you referring to your user having trouble sending messages to people on your server, or on other systems, or both?

Either way, for email delivery issues, the email log contains all the goodies regarding that.

Can you have your user try sending another message, and when it doesn’t work, look in the email log, /var/log/mail.log, for any related messages?

And then you can post the messages here, and we’ll help you diagnose what’s going on :slight_smile:

Also, does your user get any sort of error within Outlook, or does the message appear to have gone through (from Outlook’s point of view)?



Thanks for the feedback. the uses we are trying to email is users on other servers.

She gets basically 2 messages. the First messages is a message that the certificate can not be verified and the second message she gets is a message that the sent and receive (connection) time-out.

I have attached the mail.log file. I really need help on this PLEASE


Sorry, Attached the mail.log file in zipped format! [file name=mail.zip size=20801]http://www.virtualmin.com/components/com_fireboard/uploaded/files/mail.zip[/file]

Okay, here is my guess – I’m guessing that the user who’s having trouble is trying to authenticate on port 25, but their ISP is blocking that port.

Alternatives are:

  1. Have that user relay email through their ISP, rather than trying to send outgoing email via your servere

  2. Have them use SSL/TLS for outgoing SMTP authentication – which uses port 465 or 587. If it’s not already enabled, you’ll want to take a peek in your /etc/postfix/master.cf, and make sure that these lines at the top are uncommented:

submission inet n - - - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING
smtps inet n - - - - smtpd
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING

And then restart Postfix.

You can also enable those in Webmin -> Servers -> Postfix, though I’m on my way out the door and don’t recall the exact names :wink:

Just yell if you have trouble with that.