Option FollowSymlinks not allowed here

I have migrated a cpanel account across to virtualmin.
the cpanel account has a joomla website on it…and lots of extensions on the site are 2 years since last update.
my aim is to get it working on my server, then figure out how to update the site extensions as the current owners service with siteground is almost expired (2 weeks)

Site is running on php 5.6 (another pest but it is what it is)

As i have not yet changed dns over, i am trying to use Virtualmin>services>preview website to view the old joomla site i have migrated across.

I get the dreaded 500 internal server error…and virtual server apache error logs show…

Tue Nov 05 12:32:53.825931 2019…core:alert…pid 28633:tid … /home/domain/public_html/.htaccess: Option FollowSymlinks not allowed here

I found the discussion at


and tried Eriks suggestion of altering webmin file…

  • you can always prevent Virtualmin from applying that fix in the future by editing the file /etc/webmin/virtual-server/config and adding the line allow_symlinks=1 to the end of the file.*

However, the above suggestion, and no matter what else i do (such as htaccess file), Virtualmin just keeps ignoring any changes I make and this error is repeated over and over again in the Virtual Server apache error log.

why is virtulamin ignoring changes i make to either webmin or virtual server >public html htaccess file? I am missing something but not sure what?


i also note that a wordpress installation in a subdomain that came across with the cpanel migration is throwing the following error

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

Are these 2 unrelated errors? BTW my virtualmin system has a number of wordpress websites on it in other domains.

Also, I get the same error in virtual server apache error logs if i do the following…

create a phpinfo.php file and put into web root…then navigate to it via preview/phpinfo.php

public_html/.htaccess: Option FollowSymlinks not allowed here

this has me stumped. why can i not view phpinfo either???

also here is directives in Virtualmin>Services>Configure Website>
AllowOverride All Options=Exec … /etc/apache2/sites-available/domain.com.conf (16)
Require all granted /etc/apache2/sites-available/domain.com.conf (17)

<Directory /homedomain/cgi-bin>
allow from all /etc/apache2/sites-available/domain.com.conf (20)
AllowOverride All Options=Exec … /etc/apache2/sites-available/domain.com.conf (21)

RewriteEngine on /etc/apache2/sites-available/domain.com.conf (23)
RewriteCond %{HTTP_HOST} =webma … /etc/apache2/sites-available/domain.com.conf (24)
RewriteRule ^(.) https://flyst … /etc/apache2/sites-available/domain.com.conf (25)
RewriteCond %{HTTP_HOST} =admin … /etc/apache2/sites-available/domain.com.conf (26)
RewriteRule ^(.
) https://flyst … /etc/apache2/sites-available/domain.com.conf (27)
RemoveHandler .php /etc/apache2/sites-available/domain.com.conf (28)
RemoveHandler .php5.6 /etc/apache2/sites-available/domain.com.conf (29)
RemoveHandler .php7.0 /etc/apache2/sites-available/domain.com.conf (30)
RemoveHandler .php7.1 /etc/apache2/sites-available/domain.com.conf (31)
RemoveHandler .php7.2 /etc/apache2/sites-available/domain.com.conf (32)
RemoveHandler .php7.3 /etc/apache2/sites-available/domain.com.conf (33)
<FilesMatch .php$>
SetHandler proxy:fcgi://localh … /etc/apache2/sites-available/domain.com.conf (35)

AuthName "domain.com stat … /etc/apache2/sites-available/domain.com.conf (38)
AuthType Basic /etc/apache2/sites-available/domain.com.conf (39)
AuthUserFile /homedomain/.a … /etc/apache2/sites-available/domain.com.conf (40)
require valid-user /etc/apache2/sites-available/domain.com.conf (41)

I have made some headway…now i just get the error…this also happens if i try to view preview/virtual-server/link.cgi/ipaddress/http://domain.com/phpinfo.php

AH01071: Got error ‘Primary script unknown’