Only X marks appear on a web page photo.


I am trying to a virtual web server with Virtualmin GPL.

Has posted on the bulletin board to attach a photo.

Only X marks appear on a web page photo.

Then change the data folder permissions to 757 and change image file permissions to 666, a picture of a web page appears normally.

To continue automatic web hosting service,
I would like to modify Server templates for virtualmin.

How do I configure any part of virtualmin?

Could you please let me know.

On server, Folder permission , File permission, owner are below

/home 1600751 root:root

/home/mydomain 1600750 mydomain:mydomain

/home/mydomain/public_html 1600750 mydomain:mydomain

/home/mydomain/public_html/data 1600707 mydomain:mydomain

/home/mydomain/public_html/data/file 1600707 mydomain:mydomain

/home/mydomain/public_html/data/file/boardname 1600707 mydomain:mydomain

/home/mydomain/public_html/data/file/boardname/myimg.jpg 600606 mydomain:mydomain

Thank you for your answers.

here are error_log

Permission denied: /home/mydomain/public_html/data/file/boardname/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://(mydomain)/bbs/board.php?bo_table=boardname&wr_id=1&page=0&sca=&sfl=&stx=&sst=&sod=&spt=0&page=0

I wrote the above article

I want to retain the current permission.

In such state i would like to appear properly on a web page photo

This issue relates to mod_rewrite is that ?

mod_rewrite does not appear in my virtualmin box phpinfo()

your issue is related by .htaccess which has the wrong permissions. The .htaccess is placed there by your forum during install.

you need to make sure the .htaccess belongs to the correct owner and that the filepermissions are properly set.


mod_rewrite does not appear in my virtualmin box phpinfo()

Also note that mod_rewrite is an Apache module, not a PHP module, so it won’t actually show up in your phpinfo() output.

It should be no problem to enable mod_rewrite though!


Thank you for your answer.

in mydomain folder .htaccess file finding result are below.

htaccess files do I need to create?

find /home/mydomain -name .htaccess




Thank you for your answer.

in your error log there is mention of a different htaccess
Permission denied: /home/mydomain/public_html/data/file/boardname/.htaccess

There is another thread about the same error, one person “solved” it by running that domain in mod_php
The solution is to make sure the permissions are set properly and all files do indeed belong to the domain owner.

I do not understand meaning of running domain in mod_php

I am unfamiliar mod_php

Did not understand correct meaning of ypur answer, but thank for reply.

Is very difficult to beginner

For the domain with issues you can try this
Go to Virtualmin - Server Configuration - Website Options - PHP script execution mode and set this to Apache mod_php (run as Apache’s user)

see if this solves the problem