Only works


As an experiment, I have created a virtual domain:

I have created a mailbox for the account, which is supposed to be “”, however it doesn’t work. What does work is “”, but I don’t need it. So something is stopping the mapping…

As a result of what I have set up through vitualmin, my mapping file (/etc/postfix/virtual) has the following in it. christy.hobbs

Am I missing something, or just going about it the wrong way?


Hmm…that mapping should almost certainly work the way you want it to.

Are there any clues in the /var/log/maillog about where the mail goes when you send to Does it bounce?

Hi Joe

This appears to be the appropriate part of the log.

Oct 17 00:29:31 vps sendmail[[8846]]: j9H4TTsa008846:… User unknown

Oct 17 00:29:31 vps sendmail[[8846]]: j9H4TTsa008846:, size=671, class=0, nrcpts=0, proto=ESMTP, [[]]

I tried deleting and reentering the mapping. I also tried adding the email again in “Additional Email Addresses” which of course gave me the error: Failed to save mailbox : A mailbox or mail alias that clashes with the additional address ‘’ already exists.


Some troubleshooting

I’ve doubled checked that the problem is not specifically with the user “christy.hobbs” by mapping the email address to another user and testing.

I’ve made the domain explicit in The end of the file now looks like:
<blockquote>readme_directory = /usr/share/doc/postfix-2.0.18/README_FILES
alias_database = hash:/etc/postfix/aliases
myorigin = $mydomain
mydestination =
mail_spool_directory = /home/mail
virtual_alias_maps = hash:/etc/postfix/virtual
virtual_alias_domains =

Other than that I’ve been unable to find a decent step by step troubleshooting guide.