Old Version of Website

I have a VPS with a standard Virtualmin installation on Ubuntu 20.04, running without problems for two years. The only thing out of the ordinary is that you have two versions of PHP installed and running: 7.4 and 8.2.
The VPS has only one domain stored, the main website was made with a WordPress, this site was moved to a subdirectory of the root, in the root now there is a Joomla.
The Domain has Ads placed by Ezoic.
The problem I have is: when I load the domain in any internet browser (desktop and mobile), even in different countries, it keeps showing me the WordPress site (!) and in mobile it loads it with a theme that was deleted last week! I can view the Joomla site only on my desktop PC.
I wanted to know if you have any idea why this might be happening? Virtualmin keeps some kind of cache on the server side? I have restarted the VPS but still the same problem.
Thanks in advance!

Absolutely not. Virtualmin is not even the web server serving your site (that would be Apache or nginx).

This is almost certainly a DNS problem, BTW. I would guess that the server that you think is serving your website is not.

how is that possible? that VPS hosted that domain for almost 2 years with no issues.

Could be Ezoic CDN?

It’s Apache the web server

It is usually the browser that caches. I normally set them to ‘no cache’ because it drives you nuts when working on site changes.

No, the browser is not the problem, I test the site in 3 differents browsers, in 4 differents PC and mobiles and OS and in differents countries. All have the same issue

Switch this off and see if it rights itself

Yes, I think that’s the cause, I already ask to my client for it. But I want to discard a possible server side issue.

You moved your Wordpress, how did you do that? Like did you use the addon All-in-One WP Migration – WordPress plugin | WordPress.org
Also wordpress changes the .htaccess file that can cause issues.

I just copy & paste the hole site to /root/old folder and offcourse I deactivate that file, change name to htaccess.txt

The WP site now it’s not working if I try access it via browser using domain.com/old/ give me errors I think for the change of paths, that’s why is crazy the issue when I load the site from domain.com

Its not the simple with wordpress due the to database having url locations.

Can you wp-admin into the wordpress and check settings?
have you changed the URL setting in there?
also resave your permalinks

Since that worked I thought it might be browser caching. So, what is different on the desktop PC?

Since this is a public website, why not share the url here so we can see what we get?

Sure this is the website:


Check in both PC and mobile and tell me what you see please, thanks!

Desktop has ‘Recent Articles’
Mobile has ‘Latest Articles’
Mobile has a ‘hamburger’ in the upper left to join. Not on the Desktop version.

Mobile version?

You see the OLD WP site, that dont exist in that URL :rofl:

Confirmation of the issue… this is the NEW Joomla site:


Ezoic caches the web pages you need to switch it off to test, if that works get ezoic configured not to cache.
if you don’t have access to ezoic find the java code in your WP template
it should look like

<!-- Ezoic Code -->
<script>var ezoicId = some_numeric_id;</script>
<script type="text/javascript" src="//go.ezoic.net/ezoic/ezoic.js"></script>
<!-- Ezoic Code -->

and rem it out so it becomes

<!-- Ezoic Code 
<script>var ezoicId = some_numeric_id;</script>
<script type="text/javascript" src="//go.ezoic.net/ezoic/ezoic.js"></script>
<!-- Ezoic Code -->

In the root right now there is a Joomla site, I dont put any Ezoic code there.
The only file other than the Joomla ones is the ads.txt where the Google pub code is and which I imagine Ezoic uses to place the ads. If I rename it, will it correct the problem?

Reviewing the source code of the front page of the new Joomla site I can see that the code you mention is added, I suppose automatically because as I wrote above, I have not placed it.

I just got access to Ezoic and after clean cache all works fine. Thanks to all for your help!

1 Like