Ok to send emails out, no emails reaching in, no encryption on outgoing mail even though set

Hi Guys,

I haven’t been using Virtualmin for a while now. I decided to set one of my dedicated hosting servers with it to ease the setup process of new sites.

The problem:
I can send emails from my virtual server but not receive them. Also emails sent out show as not encrypted .

The setup:

  • I have domain bought with GoDaddy.
  • Server is setup on Ubuntu 14.04 LTS on amazon EC2 instance
  • A, CNAME, MX records are set at GoDaddy to point at the server. The domain itself points at the server IP. MX records point at mail.mydomain.co.uk
  • Website works as it should. You can access all the files
  • I tried to use Virtualmin scirpt to setup SSL by use of LetsEncrypt but the browsers reported ssl problem, so I used https://certbot.eff.org/#ubuntutrusty-apache certbot automatic tool to generate and install certs and now my website works on SSL
  • Security group on EC2 is set up to open all the ports necessary for email (both encrypted and non encrypted)

I installed Postfx and Dovecot through Virtualmin
I can log in to Roundcube with the email account created in virtualmin, I can send emails from there. But like mentioned above - they do not appear to be encrypted and I cannot receive any emails.

I felt like I looked everyhwere and I cant seem to find anything in configs or in logs.

Any help would be greatly appreciated!

One more comment

In mail error log Now I’ve found this:

dovecot: doveadm(my email address here): Error: Sync: User had no mail_replica in userdb


I’ve made a rookie error with my A records and my mail.domain didn’t resolve properly to the server. I can now send and receive emails but there still no encryption on outgoing mail even though it was set up in Postfix.


How was the encryption setup in Postfix?

For that, you’d typically want to add a line like this:

smtp_tls_security_level = may

Note that some folks add a “d” to smtp, but that would cause it not to work as expected.


Hi Erik!
That was it, the line was missing actually - I was following standalone tutorial on Postfix config and either it was missing some info or I did miss this line.

Thanks for your help!