Obtain ip(v6) via DHCPv6 client?

I get that this is a server, not an endpoint.
However, in my larger context, it’s just one server on my network…and I have a master router/firewall that manages the bigger picture.

I did some searching and found nothing with respect to activating a DHCPv6 client on Webmin/Virtualmin. (Same goes for ipv4 but right now v6 is my focus :wink: ).

Does anybody have experience or wisdom to share on doing this, or am I just pushing at the wind?

it is end point on your network…

It does start at your router / dhcp… to endpoint which is your server. - my light for you would be if your ISP support ipv6, enable it on your dhcp/router/modem and pass thru and then enable this within virtualmin… recheck configuration to see if virtualmin can see ipv6 and if so, set your dns settings with it and I not see why you cannot be wrong with this setup.

Virtualmin does not have a dhcpv6 client enabled. So it does not know to ask.

I can manually configure it. but it won’t happen automagically :smiley:

I have a standard install of Virtualmin behind a router configured much like yours, I imagine, and here are some screenshots


Ergo, there is some kind of dhcpv6 client at play here, unless I am mistaken.

And I bow to your superior knowledge and experience, @MrPete . I am always willing to be wrong and learn from mistakes.

Presumably, the upper screen shot is from your router.

The real question is, how did that IP (and the 192.168… ip) get into V’min? What you’re showing is NOT where the IP addresses are populated.

Here are all the places I know about:

  • Virtualmin: Addresses & Networking → Change IP…
  • Virtualmin: Server Config → Change IP…
  • Webmin: Networking->Network Config

On my install, none of those auto-populate. I had to manually enter my server IP4 address. Same appears to be true for ipv6.

What does yours have that mine does not?

I’m digging further. Very interesting/confusing…

  • There is no DHCP in my bootup/shutdown
  • If I do a search on “Packages”, isc-dhcp shows up with “unknown” install status
  • If I click to list the files, they appear to be all there

So perhaps I DO have it, but in a very wierd state :slight_smile:

  • Not listed for boot/etc
  • Not in the user interface anywhere
  • But the files are installed

No idea what that means…

Virtualmin doesn’t care how you configure your network. It’s completely out of scope for Virtualmin. You just may need to tell Virtualmin which IPs to use for what, if it can’t detect it correctly (or if it changes regularly). But, Virtualmin is not a tool for configuring your network, generally speaking.

Webmin has a Network Configuration module, which works with most of the commonly used network configuration systems on Linux (or, it did until relatively recently…these days, it doesn’t know about systemd-networkd, and has probably what I’d call beta support for netplan). You didn’t mention your distro/version, so I can’t even begin to guess what configuration tools you’re using.

I appreciate that a LOT. I do not WANT virtualmin to care how I configure my network.

I do want it to incorporate into my network however.

I think I’ve found some clues to what is strange for me. I’ll start at the end and go backwards:

  1. My ens18 ethernet interface is active in network config, but is not listed in the boot time info??!! I have no idea how that happens. Perhaps a question missed during initial install?
  2. When I tried to add it as a boot time interface, suddenly more became clear: in adding a new interface, I’m asked about obtaining the IP via DHCP etc.
    • I do not recall ever seeing that question before… and
    • Until I attempted to add this boot-time interface definition, the words “DHCP client” never showed up. In fact, it’s essentially invisible in the GUI and the documentation and all searches. (Suggestion: perhaps there should be a way to copy an “active” interface to the “boot” tab… and also to edit such things as whether an interface obtains its IP via DHCP? And also to hint at this in documentation?)
    • I’m about to reboot, which hopefully will result in a proper config of the interface. It would be nice if I could config it without reboot but that’s how the cookie crumbles.

(I’m on Debian 10 as you can see below) I see some related packages in a semi-installed (??) state, perhaps because no DHCP is/was connected to my interface?)

  • DHCP is NOT found in Bootup/Shutdown process-service list
  • DHCP IS found if I search under Installed Packages:
    • dnsmasq-base 2.80-1+deb10u1 A-E Small caching DNS proxy and DHCP/TFTP server
    • isc-dhcp-client 4.4.1-2+deb10u1 F-J DHCP client for automatically obtaining an IP address
    • isc-dhcp-common 4.4.1-2+deb10u1 F-J common manpages relevant to all of the isc-dhcp packages
  • All of these show up as: installation status: unknown; files: are present and ok
  • All of these have an “uninstall” button available, so presumably installed

OK. Time to reboot and see what happens!

Operating system Debian Linux 10
Webmin version 1.990
Usermin version 1.834
Virtualmin version 6.17-3
Authentic theme version 19.85.1

@Joe,
Something’s certainly not-quite-right:

  • WIth the interface correctly in the boot-setup side…
  • ipv4 DHCP worked as expected
  • However, there was no ipv6 traffic to discover an ipv6 address
    • Not listed in the Virtualmin server log
    • Not listed in my router log

Pretty sure I know what OUGHT to configure that… so here is the money part of /etc/network/interfaces:

iface ens18 inet dhcp

iface ens18 inet6 manual
        pre-up /sbin/modprobe -q ipv6 ; /bin/true

That doesn’t look like ipv6 is set for dhcp… even though the GUI form in network config says obtain IP “from Network discovery”

(I tried a workaround, and it works just fine: manually editing the inet6 line above to use dhcp instead of manual, then running service networking restart was all it needed.)

Ideas? Sure feels like a bug…

Ohhh. Interesting. One more tidbit:

  • By setting the inet6 entry in interfaces to “dhcp”, ie iface ens18 inet6 dhcp
  • It works perfectly and obtains the DHCPv6 ipv6 address
  • BUT: now in Network Configuration, the visible entry under “Activated at Boot” is blank
    • And if I edit that interface, it thinks ipv6 is disabled

Yep, I consider this a bug. The V’min GUI ought to provide support for DHCPv6 by allowing a “dhcp” entry in the networking/interfaces file.

Kind of with Alma8x i did have to, sorry i changed some after then manual in a config file but don’t remember which one, then it worked.
But the not activated at boot, if done some in the GUI from Virtualmin also not knowing which one or that was a cause at all causes this. Because i only did see it later at a reboot.

I didn’t post it while thought it was a “problem” i was responsible for myself.

But have see this now 2 times here in Forum, so maybe a kind of howto / help here needed, of if someone finds out how to reproduce it.

Your reply:

For this in GUI “from Network discovery” and “iface ens18 inet6 manual” i think that was correct behaviour, while “from Network discovery” is not the same as DHCP , only if DHCP then is really enabled it works to see a adress. It was for IPV6 on manual

Some links for info why IPV6 and testing:

https://ip6.nl/

Put here your external ipv6 from the domain / box:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.