Not possible to install script phpmyadmin 5.1.1 (newest) because no mysql-server

SYSTEM INFORMATION
OS type and version: CentOS Linux 8.4.2105
Webmin version: 1.973
Virtualmin version: 6.16 Pro
Related products version: phpMyAdmin 5.1.1

Hi guys,
it’s not possible to upgrade my old phpmyadmin to the newest one (5.1.1).

I try to upgrade using “scripts”.
But Virtualmin ment, that there is no MySQL-Server.
So I removed the old one and tried to install the script, but did’nt succeed because no MySQL-Server available.

Error message from VirtualMin:
This script cannot be installed, as this virtual server does not meet its requirements : phpMyAdmin requires a MySQL database

Thanks for your support.

++UPDATE: Within Virtualmin I see, that I’m using MariaDB.++

Axel

When you run the script, on the setup screen there is a section where it asks you which databases you want phpmyadmin to manage.

If there are no databases in there, then there’s nothing to manage, so phpmyadmin will not install.

That isn’t relevant. For the purposes of this, MariaDB is just another MySQL.

Your domain doesn’t have any databases or permission to create them. Give it a database, and this install script will work.

Hi guys… Thanks for your replies. Problem solved after adding an database.

1 Like