Not getting any email from my Virtualmin Server

SYSTEM INFORMATION
Not getting any email from my Virtualmin/Webmin Server
https://thenet4you.net

What can I do to fix this ???

| OS type and version | REQUIRED |
| Webmin version | REQUIRED |
| Virtualmin version | REQUIRED |
| Related packages | SUGGESTED |

would be a start so we might know the basic info.
we can only guess what users have been set up - set up a user test@your domain.net - then look at the mail.logs to see if anything is being received.
I assume that you have tried sending a test email from your Usermin account. so is it still showing as not sent in Virtualmin?

2 Likes

woops, sorry about. multi-taskin not very well here.
okay, here it is:

System hostname mark.thenet4you.net (208.104.147.195) Operating system Ubuntu Linux 22.04.2
Webmin version 2.021 Usermin version 1.861
Virtualmin version 7.7 Pro Authentic theme version 20.21
Time on system Tuesday, May 30, 2023 1:55 PM Kernel and CPU Linux 5.15.0-72-generic on x86_64
Processor information Intel(R) Xeon(R) CPU E5620 @ 2.40GHz, 16 cores CPU temperatures Core 1: 39°CCore 2: 40°CCore 10: 36°CCore 11: 38°CCore 1: 45°CCore 2: 46°CCore 10: 47°CCore 11: 50°C
System uptime 6 days, 5 hours, 49 minutes Running processes 311
CPU load averages 0.79 (1 min) 0.82 (5 mins) 0.81 (15 mins) Real memory 2.8 GiB used / 3.11 GiB cached / 15.63 GiB total
Virtual memory 0 bytes used / 3.99 GiB total Local disk space 20.34 GiB used / 79.42 GiB free / 99.77 GiB total
Package updates All installed packages are up to date

Testing external connectivity …
… the following problems were found :

Problem type Error message Possible solution
Nameserver mismatch None of the nameservers match this system : dns5.name-services.com. dns4.name-services.com. dns3.name-services.com. dns1.name-services.com. dns2.name-services.com. Verify with your DNS registrar that nameservers for the domain are set correctly.
Website request failed 500 Can’t connect to thenet4you.net:443 Make sure your system’s web server is running, that port 80 is not blocked by a firewall, and that the domain has a valid index page.
SSL website request failed 500 Can’t connect to thenet4you.net:443 Make sure your system’s web server is running, that port 443 is not blocked by a firewall, and that the domain has a valid index page.

The status of your system is being checked to ensure that all enabled features are available and properly configured …

Your system has 15.63 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB

BIND DNS server is installed

Mail server Postfix is installed and configured

Postfix is configured to support per-domain outgoing IP addresses

Apache is installed

CGI scripts can be executed using suEXEC or FCGIwrap

Apache supports HTTP/2 on your system

The following PHP execution modes are available : cgi fcgid fpm

The following PHP versions are available : 8.1.2 (/bin/php-cgi8.1)

The following PHP-FPM versions are available : 8.1.2 (php8.1-fpm)

Apache is configured to host SSL websites

MariaDB 10.6.12 is installed and running

Logrotate is installed

SpamAssassin and Procmail are installed and configured for use

ClamAV is installed and assumed to be running

Plugin AWStats reporting is installed

Plugin Protected web directories is installed

Plugin Virtualmin Support is installed

Using network interface eno1 for virtual IPs

Default IPv4 address for virtual servers is 208.104.147.195

Both user and group quotas are enabled for home and email directories

All commands needed to create and restore backups are installed

Resource limits are supported and configured correctly

The selected package management and update systems are installed

Chroot jails are available

The Virtualmin APT repository is configured correctly

… your system is ready for use by Virtualmin|

It sounds as if your DNS at your registrar was not set up correctly.

There are two ways to handle the DNS.

  1. Use the registrar.
  2. Use Virtualmin

I’m guessing the name-services.com is the default for eNom? I don’t know there interface. But if you use their DNS you usually specify the address of
your server somewhere in their DNS settings section.

If you go option 2, you must generally set up ‘glue records’ somewhere on the site. They may insist on two separate addresses. One name server isn’t considered adequate.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.