Not Creating ProFTPD Virtual Servers.

Hi Folks,

I’m brand new to virtualmin and pretty new to linux in general, so please bear with me if I’m asking frustrating or silly questions.

I recently installed virtualmin on my VPS from digital ocean running CentOS 6.5. I installed it using the automated method outlined on the virtualmin website in the documentation section for installation. Basically I downloaded the install script using wget from the url provided for the GPL version then ran it. It was straight onto a clean install, i quite literally did the following:

  1. Log into the server with default root password provided by the VPS provider (digital ocean).
  2. Changed the root password.
  3. Installed wget from yum.
  4. Installed perl from yum.
  5. Downloaded the script file from the virtualmin website using wget.
  6. Ran the script to install the virtualmin stack (webmin, virtualmin, apache, etc).

I created a couple of virtual servers and everything seemed to be working as expected, websites loading, email working etc. Then i noticed that when I try and log in via ftp as one of the users it denies me access. I noticed in the webmin configuration for ProFTPD that there are no virtual FTP servers listed for the virtual servers I created in virtualmin. I also created another virtual server in virtualmin as a test, as it goes through the list of creating the server, where it tells you its creating the apache website and the SSL website and adding the admin user etc, it doesn’t say anything about creating an FTP virtual server.

Any ideas what the problem may be? Do I need to change a setting or something somewhere?

Any help would be much appreciated.

Kind Regards, Tom

The “Virtual FTP Server” feature is not required for regular FTP operation, that’s just needed in specific special cases, like if you need to run that FTP site on a separate IP address.

Please describe what exactly happens when you try to log on to FTP. What user name are you trying, what’s in the syslog/authlog/ProFTPD log (under /var/log) at the time of login attempt? Please put shell listings in [code][/code] tags to preserve line breaks.

You can use any virtual server owner user name to log on to FTP, and also those you create as “Website FTP Access” user, or users you give a shell that allows FTP access.

Thanks for the help. Actualy I realised I changed the default ssh port and was trying to log into the server via SFTP without changing the port.

Okay, please note that SFTP is considerably different from FTP. FTP is performed by the ProFTPD daemon, while SFTP is an extension to SSH and is performed by the OpenSSH daemon.

The “Virtual FTP Server” setting does not apply to SFTP at all. Also be aware that SFTP users can browse the whole filesystem (with the usual Linux permissions in effect).