non-deletable zero length messages in usermin

Hi all,
I have a strange problem in Usermin. I have several ‘blank’ messages (zero length, no subject, no date, no sender) in a user’s inbox.
I cannot open these messages and I cannot delete them: they have no id, so if I select one and click “Delete” I get error “No message selected”, and if I click on it I get error “This message doesn’t exist anymore”.
It’s also strange that I only see these 0kb messages in Usermin: they are not showing up in Webmin > Server > Read User Mails or in Virtualmin, Edit Maibox, clicking on Inbox mail file.

I checked /var/log/maillog and /var/log/procmail.log, but found no error msgs. In /var/usermin/miniserv.error I only see the same error msgs showed in the web page, no additional info.

Thanks for any hint.


Hi Daniele,

That certainly sounds odd! Does the user in question by chance have a full quota?

Also, I’d be curious if you were to look in that particular users home directory, look in the Maildir/new and Maildir/cur directories… do you see any files in there?

Each file should be an email… I’m curious if you see a bunch of blank files in there.


Quota is ok and in the user’s mailbox (Maildir/new and Maildir/cur) I see no files corresponding to the 0kb messages.
The messages disappeared when I reordered the list (by date) (!)
I have the latest version of Virtualmin Pro.
So now the problem seems gone, but I don’t have any idea why these 0kb messages appeared…


I"m having the same issue with the latest version of Virtualmin GPL.

Re-ordering the messages didn’t seem to do anything.

These messages are some sort of remnant after deleting the messages inside Mozilla Thunderbird. It is accessing the same mailbox via IMAPS

I’m seeing the same issue as well on the latest versions of Virtualmin GPL and Usermin. Any known fixes? I tried removing dovecot.index* files to force a rebuild to no effect.

Selected “Reset sorting” in the user’s webmail interface and it’s fixed.