Nodejs proxy server down refuses to start

OS type and version Ubuntu 18.04.6
Webmin version 1.994
Virtualmin version
Related packages Nodejs installed using install script 18.5.0

When I tried it access my nodejs installation directory i’m getting an error. So I checked my nodejs install script status and it says server status is down abd when i try to start server it goes through the motion of restarting but nothing changes server is still down. What else do I need to check to make this work?

Thank you.


If you installed Node.js using Virtualmin Pro → Install Scripts page, then it must be possible to see the details of installed script using UI, i.e.:

Also, there must be a button to stop and start Node.js server. Moreover, we setup systemd unit to write logs to /home/{err|log} files, which may give you more insight on what’s really wrong.

Additionally, you can always run extra debugging by logging in as a virtual server owner user and try running manually the start the Node.js server with the following command:

/home/ /home/

When I tried to run it using your example ```
/home/ /home/

The error which came up was " /lib/x86_64-linux-gnu/ version `GLIBC_2.28' not found (required by nodejs/bin/node)"  

Is this something I need to install?

You should either be using an earlier version of Node.js or upgrade your OS.

OK. I have upgraded my OS to Ubuntu 20.04 LTS and it is working. Thank you!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.