No Route to host (installing virtualmin)

Operating system: CentOS 8
I install CentOS

I run these commands:

sudo dnf update -y
sudo dnf install -y httpd
sudo systemctl start httpd
sudo systemctl enable httpd
sudo dnf install -y mariadb mariadb-server
sudo systemctl start mariadb
sudo systemctl enable mariadb
sudo mysql_secure_installation (enter, y, then set password, y, y, y, y)
sudo dnf install -y php php-common php-pdo_mysql php-pdo php-gd php-mbstring
sudo systemctl restart httpd
sudo dnf install -y perl perl-Net-SSLeay openssl perl-Encode-Detect
sudo firewall-cmd --permanent --add-port=10000/tcp
sudo firewall-cmd --permanent --add-port=80/tcp
sudo firewall-cmd --reload
dnf install wget screen vim curl -y
dnf install epel-release -y
dnf update -y
sudo hostamectl set-hostname hosting.basedhosting.com
sudo wget http://software.virtualmin.com/gpl/scripts/install.sh
sudo /bin/sh install.sh

And when i get to downloading virtualmin, i’m returned with this: Conecting to Virtualmin… No Route to Host

Seems like DNS issue there. Did you try running dig on virtualmin.com and get any results?

1 Like

@justin_wallis It’s worth mentioning the central point – installation processes it completely wrong!

— DO NOT DO IT —

Start with a freshly installed , Grade A supported Operating System on your server or VPS. CentOS and Ubuntu LTS are very popular options for hosting, and are a safe choice, but any Grade A supported system should work fine. Be sure to configure your system with a fully qualified domain name, as it will save you a lot of time and documentation spelunking later.


https://www.virtualmin.com/download

3 Likes

Thank you!! I Just did a fresh install and go the same thing :frowning:

Try that on software.virtualmin.com

They use a different IP for that

1 Like

Super thankful for the help. This is with “dig software.virtualmin.com”. Looks like a similar output.

This is my virtualmin config btw: (next posts)

When i hit apply, the “current hostname” switches back to localhost.localdomain
Should i try a different DNS maybe?

Screenshot 1:

Thank you! So, immediately after installing and logging in to centOS, i should download and run virtualmin install script? No other prerequisites? should i set hostname ( sudo hostamectl set-hostname hosting.basedhosting.com )

Ah you running GUI. Have not done that with an OS yet except clients running Server 2016 and 2019.

Try adding 8.8.8.8 and 8.8.4.4 to the DNS and you should be good to access the virtualmin download.

Setting hostname is fine (good even, as our script isn’t always able to set it, depending on how networking is setup and some other factors).

But, you don’t seem to have network connectivity, at least not to our software server. I don’t know how to guide you on fixing that. It works fine for me, and from every server I can test from.

Your DNS seems to be working…that (163.172.162.254) is the correct IP for software.virtualmin.com (currently, though it can change at any time).

You could try using https instead of http. Maybe just port 80 is broken for some reason. e.g. https://software.virtualmin.com/gpl/scripts/install.sh

2 Likes

I had to use the automatic ipv4 settings on the centos installation for virtualmin to download.

I did a ‘minimal install’ no extras checked, then logged into centos and the only commands i ran were:

sudo dnf install -y wget
sudo hostnamectl set-hostname hosting.basedhosting.com
sudo wget http://software.virtualmin .com/gpl/scripts/install.sh
sudo /bin/sh install.sh

So, i don’t need to run any of these commands? Can they all be done within Virtualmin? if not, which ones should i still run?

sudo dnf update -y
sudo dnf install -y wget perl perl-Net-SSLeay openssl perl-Encode-Detect
sudo dnf install epel-release -y
sudo dnf install -y httpd
sudo systemctl start httpd
sudo systemctl enable httpd
sudo dnf install -y mariadb mariadb-server
sudo systemctl start mariadb
sudo systemctl enable mariadb
sudo mysql_secure_installation (enter, y, then set password, y, y, y, y)
sudo dnf install -y php php-common php-pdo_mysql php-pdo php-gd php-mbstring
sudo systemctl restart httpd
sudo firewall-cmd --permanent --add-port=10000/tcp
sudo firewall-cmd --permanent --add-port=80/tcp
sudo firewall-cmd –-reload

Thank you


What should i do about SuExec?

After the Post install wizard:

I should pretty much run these steps now i assume. At least i got this far, i took a snapshot to save the trouble of getting here i’ve had.

https://bobcares.com/blog/webmin-change-ip-address/

Change the info in “Network Config” and try again? or maybe “change ip address” section. I’m having trouble knowing which ip to put where. I might end up paying for help at this point

No. Our instructions say explicitly not to do any of that. So…who told you to do all that? It definitely wasn’t us or our documentation.

No. That is about changing the IP address of your server using Webmin’s network configuration module. Completely unrelated to your problem. Search that specific error here in our forum for plenty of other people discussing it (it’s a common issue because it’s common for people to try Virtualmin on virtual machines with wonky/weird/broken networking).

The problem you have is that Virtualmin can’t figure out what IP to use for virtual hosts. You just need to tell it what IP you want it to use for the external address (mostly in DNS records…but, since you’re just tinkering with a VM on your local machine, you can’t host DNS, anyway, so maybe just turn that feature off).

There are no steps to “prepare” your OS. None. Zero. At all.

Install your OS.

Log in.

Then do this: wget http://software.virtualmin.com/gpl/scripts/install.sh

Then do this: sudo /bin/sh install.sh

That’s it. It’s that easy. You are making this thing far, far harder than it has to be.

3 Likes

Thanks Man! I just watched the wrong tutorial, first one that came up unfortunately https://youtu.be/tbu0K43eCfw I know it may seem like i’m amateur, but it’s just new to me.

So, i actually have router, then managed switch, then a server i’m running this from. I installed a HyperV, then installed CentOS on that. I also have the necessary ports open. I also do want to host the DNS, (i think the BIND thing). I’m pointing it from my domain manager, and i believe i have the necessary dns records set.