No QR code displayed for Google Authenticator

OS type and version Almalinux 9.3
Webmin version 2.105

When enabling 2FA with google authenticator it loads the key and it works. But there is no QR code displayed. It is a little annoying entering it manually as I plan to enable this for multiple users.

what could be the issue for the QR code not to display? Is there some dependancy I need to install?

It comes from Google. Are you blocking some Google URLs in your browser?

I tried without ublock origin browser plugin but the issue is the same.

I use multiple browsers. I leave at least one ‘default’. Even that is problematic as browsers are now sometimes being kind enough to make security decisions on their own. Might try a clean copy of Chrome for this one?

Use Inspect in the browser, the network tab will show if there is a issue with connecting to google.

1 Like

It also doesnt work in vanilla chrome.

this is the error:

failed net::ERR_BLOCKED_BY_ORB


Is it possible to change API if the google one is broken?

maybe this could display it:

If the Google one is broken, I’d rather we bundle a local one. Depending on remote ones leaves quite a few ways for it to fail.

yes probably safer too.

maybe someone else can confirm or reproduce the problem.

I think will be fixed in next webmin

Remove un-needed param · webmin/webmin@64211e4 · GitHub

I added the patch and no qr code getting generated.

plese tell here if it is still broken

2FA does not load QR code · Issue #2115 · webmin/webmin (

The fix hasn’t been delivered yet. It will be included in upcoming Webmin 2.110 release.

You don’t need QR code to make things work, just enter provided key manually.

yes I understood it like stefan tried the new url parameters manually.

Jamie made an additional patch to use qrencode or a Perl QR code library, if either is available, which removes the dependence on an outside web service.

I got it to work in chrome after 2 goes but get broken link in firefox

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.