No PHP versions page under Server Configuration

I’m running Virtualmin 6.16 / Webmin 1.973 on top of Ubuntu 18.04.5, but last night I’ve found that I’ve lost the PHP versions page under Server Configuration. That seems to be replaced by PHP options page, but my problem is that whatever I set under that page for a virtual server, the php.ini file is being read from here: /etc/php/7.4/fpm/php.ini, instead of here: /home/my-domain/etc/php7.4/php.ini.

just question, is 18… eol or its still supported?

If you use php-fpm than path for the php.ini is correct: /etc/php/7.4/fpm/php.ini under /home/my-domain/etc/php7.4/php.ini you can place values to override defaults.

1 Like

@unborn it should be, according to this: Ubuntu release cycle | Ubuntu, at least the security detail.

@miojamo In my case, changes to the /home/my-domain/etc/php7.4/php.ini do not take effect.

I am jumping in to expand upon what @miojamo has correctly stated: if you are using PHP-FPM then the path is correct and you must use:
Virtualmin → Services → PHP-FPM Configuration (for Apache)
Virtualmin → Services → PHP Configuration (for Nginx)

Custom settings to PHP-FPM must be applied via this Virtualmin option. These will be applied to the specific PHP-FPM pool config for that virtual server.

Hey @Ilia, unless there is a reason to use just PHP for Nginx and PHP-FPM for Apache, in a future release of Virtualmin could we have have uniformity in nomenclature please?



Yes, I’ll double check on that tomorrow and update this thread.

Thanks for the heads up!



But why aren’t changes in /home/my-domain/etc/php7.4/php.ini taking place?
WordPress health page prints default values for the settings that I customized in the php.ini file.
After each change I do:

service apache2 restart
service php7.4-fpm restart

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.