No longer receiving updates

I used to get updates weekly
I have not had any updates in 2-3 months now, is this normal ?
Webmin 1.996, Virtualmin 7.1-1, usermin 1.850
built on Ubuntu 18.04.6
did i block a IP address that was checking for an update ?


What most probably is going to fix your problem is correcting Virtualmin repos. It can be done by downloading an official script and running it with --setup param only, to configure Virtualmin repositories and exit:

/usr/bin/sudo /bin/sh --setup
/usr/bin/apt-get clean
/usr/bin/apt-get update
/usr/bin/apt-get upgrade
1 Like

this is a live ecommerce server, and anxious to make such radical changes
…confused why this should suddenly stop 2-3 months ago, as used to get daily updates
I cannot afford this server to go down or break anything, but equally concerned i have not had updates and security fixes for weeks
… asking if there was an update that broke this, as i did not install anything new apart from regular updates, and of course adding IP address to block in CSF (which is what i was thinking if i blocked access to a webmin server or such that was providing a repo ?)

I would personally be much more worried to run outdated Webmin version than being afraid of updates going wrong.

This is not even a change. Running these commands would just fix your Virtualmin repos and allow to install latest Webmin and Virtualmin packages. As you run mentioned commands, all you should do afterwards is to make sure that your system is set to use /vm/6 repos (if that is an old installation) to make sure your MySQL won’t be replaced with MariaDB.

What is the content of /etc/apt/sources.list.d/virtualmin.list file?

deb Index of /vm/6/gpl/apt virtualmin-bionic main
deb Index of /vm/6/gpl/apt virtualmin-universal main

--2022-11-05 18:39:37--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 42299 (41K) [application/x-sh]
Saving to: ''                            100%[======================================================================>]  41.31K   233KB/s    in 0.2s

2022-11-05 18:39:37 (233 KB/s) - '' saved [42299/42299]

root@server:/# /usr/bin/sudo /bin/sh --setup

[INFO] Started Virtualmin 6 GPL software repositories setup
▣ Phase 1 of 1: Setup
Downloading Virtualmin 6 key                                            [ OK ]]
Installing Virtualmin 6 key                                             [ OK ]]
Downloading Webmin key                                                  [ OK ]]
Installing Webmin key                                                   [ OK ]]
Downloading repository metadata                                         [ OK ]]
Enabling universe repositories, if not already available                [ OK ]]
Disabling cdrom: repositories                                           [ OK ]]
Cleaning up software repo metadata                                      [ OK ]]
[SUCCESS] Repository configuration successful. You can now install Virtualmin
[SUCCESS] components using your OS package manager.
root@server:/# /usr/bin/apt-get clean
root@server:/# /usr/bin/apt-get update
Hit:1 bionic InRelease
Hit:2 bionic-security InRelease
Hit:3 bionic InRelease
Hit:4 bionic-updates InRelease
Hit:5 bionic InRelease
Hit:6 bionic InRelease
Ign:7 sarge InRelease
Hit:8 sarge Release
Hit:9 virtualmin-bionic InRelease
Hit:10 virtualmin-universal InRelease
Reading package lists... Done
root@server:/# cat /etc/apt/sources.list.d/virtualmin.list
deb [signed-by=/usr/share/keyrings/debian-virtualmin-6.gpg] virtualmin-bionic main
deb [signed-by=/usr/share/keyrings/debian-virtualmin-6.gpg] virtualmin-universal main
root@server:/# /usr/bin/apt-get upgrade
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So, should i run sudo dpkg --configure -a ?

After i deleted the #padding, it installed ok.

I did see 2 ‘Fails’ assume ok:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_COLLATE = "C",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C")


Unpacking libdbus-1-3:amd64 (1.12.2-1ubuntu1.4) over (1.12.2-1ubuntu1.3) 
Setting up systemd (237-3ubuntu10.56) ...
Failed to try-restart systemd-resolved.service: Unit systemd-resolved.service is masked.
(Reading database ... 150205 files and directories currently installed.)
Preparing to unpack .../00-systemd-sysv_237-3ubuntu10.56_amd64.deb ...

After a reboot, I see:
Webmin 2.001 , Virtualmin 7.3-1, usermin 1.860, authentic theme 20.01.1:5
(from Webmin 1.996, Virtualmin 7.1-1, usermin 1.850)

How will I know if I will get future auto updates?

coz you have set the correct repositories

no, the repositories were correct, i never changed them, and they were always correct…

Then you would have been getting updates (if you’re getting updates now, that indicates nothing was wrong with the scheduled job that checks for updates, so it had to be repositories either disabled or deleted).

no idea, how can i check ?
if i hit ‘refresh available packages’ - of course, it was only updated yesterday, so unlikely updates…
but the action is the same i was performing before, and same repose, all works but no updates shown
i guess i will followup on this thread in a week or 2 and recheck

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.