No FPM server bootup action found

Operating system: CentOS
OS version: 8

I have three PHP versions installed: 7.4, 7.2, and 5.6. I presently have two FPM engines running, 7.4 and 5.6. I installed 7.2 tonight to test a site; it is presently enabled but not running, because I don’t need it until I can select the PHP version to test it.

Rechecking the Virtualmin configuration gives this error message:

The following PHP-FPM versions cannot be used : 5.6.40 (No FPM server bootup action found) 7.2.34 (No FPM server bootup action found)

This is the status of the systemd service files.

# systemctl list-unit-files | grep fpm

php-fpm.service enabled
php56-php-fpm.service enabled
php72-php-fpm.service enabled

Until recently this all worked without problems. Tonight when I tried to change the PHP version in one of the virtual hosts, it says basically that there is only one version installed, so there is nothing to select. This is true even for the sites running on PHP 5.6; the FPM engine is running, and the sites are up, but Virtualmin does not recognize the different PHP versions. Virtualmin is version 6.14.

Any idea what might have changed, or why the configuration recheck fails? I’ve not tried to peel apart the code to see what it looks for to think that an FPM engine is available. Thanks…


What was the method you used to add the new PHP version?

Please provide the commands you issued.

Best Regards,
Peter Knowles | TPN Solutions

Hello, and thanks for the reply. I installed them via the Remi repositories. That was done a few months ago, so I no longer have the exact commands, but it was a matter of installing the Remi repositories and then installing the php versions via standard rpm commands.

After installing the alternate php versions, until recently I could choose between 7.4 and 5.6. I don’t know when it stopped working because that is not something I do often.

– Michael

This is starting to look like a CentOS 8 bug.

This morning I found in the Virtualmin code that it isses a command "systemctl show php???.service’ to find the status of a particular FPM service. Running that manually, systemctl returns “Failed to parse bus message: Invalid argument” and other stuff, but it does not return UnitFileState or Description, which the Virtualmin code is looking for to determine if the service is enabled.

I have found a discussion of a Redhat bug that appears to be what I am seeing:

I must wait until tonight to reboot the system to see if I can clear this up. When I have results I will post again.

This is resolved. I confirm that I was seeing the bug in CentOS 8 I indicated previously.

The system is on Linode, and a few weeks ago I opted to boot a Linode maintained version 5 kernel. That tripped the bug, in that recent versionos of systemctl have a dependency on the kernel that I have never seen before. Tonight I booted the system back to the C8 version 4 kernel, and now Virtualmin allows me to choose the version of php to run for a given vhost.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.