No boot-time interface found for eth0 on Ubuntu

SYSTEM INFORMATION
**OS type and version:**Ubuntu 20.04
Webmin version: 1.981
**Virtualmin version:**6.17-3

Hi Community,

having a problem setting up IPv6 for a new VPS. My VPS is from Contabo, by creating a virtual server in Virtualmin with IPv6 I’m getting this error:

No boot-time interface found for eth0

Going a bit deeper, in my Network interfaces in Webmin, I have at boot the device “ens18”, eth0 and lo are in the active now tab.
I’m not sure, but I think here is the issue.
Doing an “ip a” on Putty, I just have the eth0 and the lo device.
Does anyone know, maybe a workaround?

Thanks a lot

CENTOS here but WEBMIN > Netwroking >Network configuration >
Network Interfaces > [Activated at Boot] >eth0 gives some info you see there ipv4 ipv6 and yes no Activate at boot?

Don’t screw around with your network interfaces!

Just tell Virtualmin the right interface to use in Virtualmin Configuration.

Thanks a lot @Joe for your answer ,

can you give me a hint where I can change that?

Thanks a lot :slightly_smiling_face:

@fabi
That Virtualmin > System settings > virtualmin Configuration > category there
Networking settings*

(But the ipv6 contabo wasn’t at our box active at boot (time).)

1 Like

You need to check with contabo to ensure correctness of network and that you understand which interface is active. IPV6 may not be activated which means you need to manually enable this with a new interface.

1 Like

Thanks a lot to all of you,

I think I have found the error. When I do an “ip a”, I can’t see any device named “ens 18”, just eth0 and the lo device.
Going into the netplan.yaml config, it looks like this:

network:
version: 2
renderer: networkd
ethernets:
ens18:

I changed there the ens18: to eth0:

Now it works like butter, I can add IPv6 addresses to the server without any problem.

I think so far, everything is correct, it works without issues :slight_smile: That’s maybe a bug from Contabo?

Thanks a lot to all