No action buttion on Create Virtual Server

SYSTEM INFORMATION
OS type and version CentOS Linux release 7.9.2009
Webmin version 2.105
Virtualmin version 7.10.0
Related packages not sure what these would be

I’ve not been able to find a post like this, so opened a new one.

Clicking on Create Virtual Server opens the data collection page after a small delay, but there is no button to click to actually create the site. The bottom element is the ‘IP Address and Forwarding’ dropdown menu.

Opening ‘IP Address and Forwarding’ there is a message ‘Failed to work out externally visible IP address’ with a ?; mousing over the ? shows ‘virtual-server-lib-funcs.pl (line 18813)’. The default ip address is selected and is correct.

In the webmin.error log I see the following:

/virtual-server/domain_form.cgi?generic=1&gparent=15529347569787 : Failed to work out externally visible IP address

Is the external ip address problem the reason the action button is not shown? I will be glad to supply additional information as needed. Thanks…

Can you post a screenshot of what you’re talking about? (Also, if this is a new server, using CentOS 7 is a disaster. It reaches EOL in June! Even if it’s not new, you should be in the process of migrating to a new system with a newer OS.)

This is the bottom part, just to keep the image small.

RE Centos 7, I admin the system for a client. I thought it EOL’d around November, so I will notify them to work toward migrating to Rocky 8 or 9. 8 EOLs in 2029, 9 in 2032, and by then I will have backed out of admining anything.

Can you scroll down?

Thanks for the reply. No, the rest of the page below the creation frame is empty.

I need to see the whole thing. At least the whole content pane. I still don’t know what problem you’re trying to say you’re having.

Look in the Web Developer tools console. Are there any errors? I can’t think of any reason for the behavior you’re seeing, assuming it’s not super low on memory.

Thanks for the followup. It is a 16g system, about 8g used. Watching the Web Developer Tools console, there are no messages.

I left of the top bar because it has the base domains of the system; that may not matter, but I am trying to minimize specific information about the server. If you want to see that I can try to get it to you.

Thanks. The problem is that there is no button to actually create the site; I don’t know what it would say, but from long use I would expect it to be a green or amber button. I tried filling in the needed fields, thinking that it might not appear until the form was filled, but that did not work.

I have not added a new virtual site for some time, meaning several releases of virtualmin, so I’ve not seen the changes to the interface.

maybe like this ?

Thanks, @jimr1, that is what it should look like, but the ‘Create Server’ button is missing. I have an idea that the failure to work out an externally visible ip is why the button is not showing, but I’m not sure of that.

Hi Joe, I commented line 18813 in virtual-server-lib-funcs.pl, and that fixed the problem; the ‘Create Server’ button appears now.

#$rv || &error($text{‘newdynip_eext’});

I have run Recheck Configuration, and it shows this in tan font:

Could not detect external IPv4 address

So the question seems to be, what is causing the error ‘Failed to work out externally visible IP address’?

Not sure, but you can manually specify it in Virtualmin Configuration, which will make it work again.

What’s the output of ip ad sh?

And, is this server maybe behind a masquerading/NATted router or something and only has a private IP locally? In that case, Virtualmin would try to make a request to our server to ask what IP it has…and if there’s a firewall preventing that, it’d maybe hang (if you have an outdated Virtualmin version, there was a misfeature where the create server page tried to check the IP in realtime, which is shouldn’t do because it can fail or be slow) or fail.

Thanks much, that fixed it.

No nat/masq.

I had forgotten that in addition to eth0 there is a tailscale0 interface on that system, and it was set to automatically detect the interface from which to take the ip. The tailscale0 address is a 100. address that is effectively private; perhaps that might be the problem, I don’t know how virtualmin determines the if to use. In any case I set it to use eth0, and I set the ip manually.

Thanks again for the help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.