Nginx fails to start at all (NOT an Ubuntu 24 OS!)

OS type and version Ubuntu Linux 20.04.6
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

Oops, I may have found another bug in the LEMP stack?

I went ahead with:

and the reboot that was prompted following install

But now that old bug (the one where nginx fails to auto restart after a reboot) has reappeared!

trouble is worse now as the nginx webserver totally refuses to start:

indicating something is wrong with virtualmin-nginx/start.cgi (line 12)

Fortunately, it is only a development server.
Unfortunately, it is very busy (or was) and users are getting irate.

Just wait it out a fix should be a day or so … maybe

it would help if I could actually find the file indicated or undo the install
I have tried a backup to yesterday but a lot of other water has passed - these devs are vey active folk I really need to update backup policy to < hourly)

I had the same. Seems it at somepoint and for some reason decided to install Apache.
Go to - System - Bootup and Shutdown and disable and stop Apache and Nginx should start. as you cant have 2 services on port 80.

I did not install this on my own so i have no idea why apache snuk in with a update. :roll_eyes:

Start-Date: 2024-05-14 03:38:33
Commandline: apt-get -y install virtualmin-lemp-stack
Install: libaprutil1-dbd-sqlite3:amd64 (1.6.1-5ubuntu4.22.04.2, automatic), apache2-data:amd64 (2.4.52-1ubuntu4.9, automatic), apache2-bin:amd64 (2.4.52-1ubuntu4.9, automatic), php-json:amd64 (2:8.1+92ubuntu1, automatic), apache2:amd64 (2.4.52-1ubuntu4.9, automatic), libaprutil1-ldap:amd64 (1.6.1-5ubuntu4.22.04.2, automatic)
Upgrade: virtualmin-lemp-stack:amd64 (7.0.4-1, 7.0.5-1)
End-Date: 2024-05-14 03:38:44

Operating system Ubuntu Linux 22.04.4
Webmin version 2.111 Usermin version 2.010
Virtualmin version 7.10.0 Pro Authentic theme version 21.10
Time on system [Wednesday, May 15, 2024 4:12 PM] Kernel and CPU Linux 5.15.0-1063-realtime on x86_64

1 Like

Thanks that solved it. Once I also “disabled on boot” and then rebooted.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.