New Virtualmin virtual-server module version 3.39

Hi all,
I’ve rolled out version 3.39 of the Virtualmin virtual-server module. This is a big update with a lot of bugfixes, new features, and assorted tasty treats. You’ll enjoy it.
Changes since 3.38:

[]Improved the layout of the Disk Usage page, using tabs.[/]

[]Added the --template option to[/]

[]Added a column to the list of installed scripts to show if it is the latest version or not.[/]

[]Added a star rating system (out of 5) for script installers. Users can rate installed scripts, and ratings for those available are collated based on submissions from Virtualmin Pro users and displayed in the list of scripts available.[/]

[]Validation of MySQL and PostgreSQL features now check that the database user exists too.[/]

[]Added plaintext password to output.[/]

[]Added the command-line script for re-sending a domain’s signup email.[/]

[]Added Module Config options for a hosting provider logo.[/]

[]Updated the Wordpress script installer to version 2.1.3, and Gallery to 2.2.1.[/]

[]Fixed bugs that prevent owner limits from being mass-updated, and caused bandwidth limits to be un-necessarily changed.[/]

[]Re-factored all code for displaying quota fields, so that the text box is greyed out when ‘Unlimited’ is selected.[/]

[]Fixed the cPanel migration code to handle new Maildir++ format mailboxes.[/]

[]Added Prev/Next buttons to template form, for easily navigating through sections.[/]

[]Email to all domain owners and all mailboxes in a domain can now use substitutions like ${DOM} and ${QUOTA}.[/]

[]Added the virtusertable plugin to the Squirrelmail script installer, so that users can login with their email addresses.[/]

[]Change the Module Config option for new domain passwords to add an option to require the password to be entered twice.[/]

[]Added the Search Mail Logs page, which can show the destination of email to your system regardless of the final delivery method (local, autoreply, spam, virus, or forwarded). To support this, Virtualmin configures Procmail to log the destination file for all email it processes, to /var/log/procmail.log.[/]

[]Added the command-line script, with the same functionality as the web-based mail search.[/]

[]Removed the ‘All virtual servers are name-based’ Module Config option, as this function has been superceded by support for multiple shared IP addresses (and was confusing to boot).[/]

[]Added a Module Config option for a Unix group to add all domain owners to.
Added arrows to the Custom Links page to move them up and down.[/

[]Added a new section to the Custom Links page for defining categories, and menus for assiging links into categories.[/]

[]Added an option in the Apache website section of the server templates for specifying a php.ini file to copy into new virtual servers’ ~/etc directory, instead of the global default. This .ini file can also contain substitutions like ${DOM} and ${HOME}.[/]

[]Added a server template option to make virtual servers’ php.ini files non-editable by the server owner.[/]


If you’ve installed the security-updates module, you can use it to update this package. If you prefer to hit the command line:
To upgrade on Red Hat based systems:
yum update wbm-virtual-server
On SUSE systems:
yast -i wbm-virtual-server
On Mandriva systems:
urpmi.update -a
urpmi wbm-virtual-server
And on Debian and Ubuntu systems:
apt-get update
apt-get install webmin-virtual-server
To upgrade on systems installed using .wbm packages, download the module from:
Using your serial number as the username and your license key as the password. Then install it using the Webmin Modules module.
As always, let us know about any bugs you find by filing a bug in the bug tracker.

I also put this in as a bug

I’m changing IPs on the severs and was going to take the opportunity to test clustering the update. I updated to 3.39 on one box and tried adding BIND cluster servers that kept failing do to no route. I noticed a problem on the port, that the 5th digit incremented on every attempt. I updated the VM on another box and got the same result

Adding …
Failed to connect to fastrpc.cgi : Failed to connect to : No route to host

note: 10003

I forgot to note that the port entered for the server reamins the same. It’s just RPC call that seems to increment the port, irregardless of the port assignment.

This same thing occurs also when trying to add it as a cluster server.

I got the same issue here – even my dns doesn’t want to create on my slave server so I have to create it manually.

It’s a odd bug that’s for sure. It did work at one point in time though.