New virtualmin install inside container not redirecting to virtual server

OS type and version Debian Linux 10
Webmin version 2.021
Virtualmin version 7.7

I have this strange problem that seems to have happened since I moved one of my virtual server to another virtualmin. Also, note it was from centos to debian

I installed an app via git, which has two directories it needs to be able to write in. On the centos original machine I did not have writable problems with PHP, however on this new virtualmin machine I have this problem

When I checked the phpinfo() I can see that apache is not running as the domain owner on the new virtual machine, it is running as www-data

in phpinfo()


Variable Value
USER www-data
HOME /var/www

However, on any other virtualmin, same app, if I check other domains it holds


Variable Value
USER domainowner
HOME /home/domainowner

So there is something wrong here, and I recall seeing once there was a setting in virtualmin to “run site as owner” or something to this regard.

So under this virtual server, I went to Server Configuration → PHP Options, and noticed it was disabled. Ok, so I put it to FPM. Nothing changed and I it is still set as running as apache www-data

I then tried FCGId and I get this error and the site went down!

Changing PHP execution mode to FCGId ..
.. change failed : No <Directory> section found for mod_fcgid directives

When I compare .conf files from another virtualmin running fine, the files look mostly the same, so I’m not sure why it is complaining.

Regardless of the settings, even changing the PHP version, and it says it worked, when I check phpinfo() the PHP versions stays the same and the owner is always the same.

Any ideas why I cannot get this virtual server to run under the owner?

in the apache config file /etc/apache2/sites-available/ it has its SuexecUserGroup as the correct user that should be for his website. I’m not really sure what to do to get this working properly.